Bug 1004897 - Unable to update a repository's feed
Unable to update a repository's feed
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
Unspecified Unspecified
high Severity unspecified
: ---
: 2.3.0
Assigned To: Barnaby Court
Preethi Thomas
:
: 845010 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 13:18 EDT by Jay Dobies
Modified: 2013-12-09 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:31:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2013-09-05 13:18:15 EDT
I had a repository sync from one of the F19 mirrors. There were some issues (I think the external repo started rejecting me) so I tried to change the feed to use a different feed. It looks like the conflict detection is testing it against all repositories, not all *other* repositories.

╭─[waterdeep]─[~]─[]─●
╰─➤ pulp-admin rpm repo update --repo-id f19-64 --feed http://download.fedoraproject.org/pub/fedora/linux/releases/19/Fedora/x86_64/os/
The server indicated one or more values were incorrect. The server provided the
following error message:

   Relative url '/fedora/linux/releases/19/Fedora/x86_64/os/' conflicts with
existing relative_url of '/fedora/linux/releases/19/Fedora/x86_64/os/' from repo
'f19-64'

More information can be found in the client log file ~/.pulp/admin.log.
Comment 1 Jay Dobies 2013-09-05 13:48:05 EDT
It may be bigger than I previously thought and not allowing any updates to a repository. I tried to update the repo to serve HTTP:

╭─[waterdeep]─[~]─[]─●
╰─➤ pulp-admin rpm repo update --repo-id f19 --serve-https true
The server indicated one or more values were incorrect. The server provided the
following error message:

   Relative url '/fedora/linux/releases/19/Fedora/x86_64/os/' conflicts with
existing relative_url of '/fedora/linux/releases/19/Fedora/x86_64/os/' from repo
'f19'

More information can be found in the client log file ~/.pulp/admin.log.


Part of me wondered if the client was always deriving the relative_url, even on an update, and passing that in. But there's no way the client would have the feed in this case, so I still suspect there's a bug in the changes to the relative_url validation that's causing this.
Comment 2 Barnaby Court 2013-09-06 10:12:30 EDT
Definitely a bug where the repository being updated was not being precluded from the relative_url check.  Pull requests with the updates for this bug have been submitted:
https://github.com/pulp/pulp/pull/606
https://github.com/pulp/pulp_rpm/pull/329
Comment 3 Barnaby Court 2013-09-09 13:23:00 EDT
*** Bug 845010 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Ortel 2013-09-12 18:35:53 EDT
build: 2.3.0-0.10.alpha
Comment 5 Preethi Thomas 2013-09-17 15:21:27 EDT
verified

[root@pulp-v2-server ~]# rpm -qa pulp-server
pulp-server-2.3.0-0.12.alpha.el6.noarch
[root@pulp-v2-server ~]# 


[root@pulp-v2-server ~]# pulp-admin rpm repo create --repo-id pulp --feed http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/fedora-19/x86_64/
Successfully created repository [pulp]

[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# pulp-admin rpm repo sync run --repo-id pulp
+----------------------------------------------------------------------+
                    Synchronizing Repository [pulp]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       42/42 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Publishing packages...
[==================================================] 100%
Packages: 42/42 items
... completed

Publishing distributions...
[==================================================] 100%
Distributions: 0/0 items
... completed

Generating metadata
[\]
... completed

Publishing repository over HTTPS
[-]
... completed

[root@pulp-v2-server ~]# pulp-admin rpm repo update --repo-id pulp --feed http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/fedora-19/i386/
Repository [pulp] successfully updated

[root@pulp-v2-server ~]# pulp-admin rpm repo sync run --repo-id pulp+----------------------------------------------------------------------+
                    Synchronizing Repository [pulp]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       42/42 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Publishing packages...
[==================================================] 100%
Packages: 84/84 items
... completed

Publishing distributions...
[==================================================] 100%
Distributions: 0/0 items
... completed

Generating metadata
[|]
... completed

Publishing repository over HTTPS
[-]
... completed

[root@pulp-v2-server ~]#
Comment 6 Preethi Thomas 2013-12-09 09:31:26 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.