This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004949 - invalid gdb header
invalid gdb header
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
18
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 16:09 EDT by xdegaye
Modified: 2013-09-24 19:02 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdb-7.6.1-41.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-22 20:30:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xdegaye 2013-09-05 16:09:04 EDT
Description of problem:
The Fedora gdb header is:

GNU gdb (GDB) Fedora (7.6-32.fc19)

This is non conformant to GNU coding standards as specified in section
4.7.1 of http://www.gnu.org/prep/standards/standards.html:

    "The first line is meant to be easy for a program to parse; the
    version number proper starts after the last space."
                                 ^^^^^^^^^^^^^^^^^^^^

See
http://stackoverflow.com/questions/18157954/fedora-19-pyclewn-cant-find-gdb-version
for why this is an annoying bug.


Version-Release number of selected component (if applicable):
Version 7.6-32.fc19


How reproducible:

Steps to Reproduce:
1.  Run:
    gdb --version

Actual results:
    GNU gdb (GDB) Fedora (7.6-32.fc19)

Expected results:
    GNU gdb (GDB) Fedora 7.6-32.fc19
Comment 1 xdegaye 2013-09-05 16:19:01 EDT
Note that this is the only mean provided by gdb, for front-ends to
learn the gdb version they are running, wether they are interfacing
with the cli or with gdb/mi.  This is the reason why this line MUST
strictly conform to the GNU coding standards.
Comment 2 Jan Kratochvil 2013-09-09 12:07:41 EDT
It no longer prints the exception
  "cannot find the gdb version"
although pyclewn fails here on some other error.
Comment 3 Fedora Update System 2013-09-09 12:33:21 EDT
gdb-7.6.1-41.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gdb-7.6.1-41.fc19
Comment 4 Fedora Update System 2013-09-09 12:33:26 EDT
gdb-7.5.1-42.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdb-7.5.1-42.fc18
Comment 5 Fedora Update System 2013-09-09 12:33:29 EDT
gdb-7.6.50.20130731-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gdb-7.6.50.20130731-10.fc20
Comment 6 Fedora Update System 2013-09-09 19:54:01 EDT
Package gdb-7.5.1-42.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdb-7.5.1-42.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16214/gdb-7.5.1-42.fc18
then log in and leave karma (feedback).
Comment 7 xdegaye 2013-09-10 06:05:24 EDT
Running debian, so I cannot yum or even use the downloaded and
extracted binary from
http://koji.fedoraproject.org/koji/buildinfo?buildID=463174
(missing shared library).

Since this is the only change at
http://pkgs.fedoraproject.org/cgit/gdb.git/commit/?h=f18
I did check that pyclewn 1.10 (the latest stable release) now runs
fine after changing the version.in file of upstream gdb 7.5.1 to:

    Red Hat Enterprise Linux 7.5.1-42.fc18
or
    Fedora 7.5.1-42.fc18

Don't know if this is good enough for a karma.
Comment 8 Jan Kratochvil 2013-09-10 06:11:29 EDT
(In reply to xdegaye from comment #7)
> Don't know if this is good enough for a karma.

It is not but anyway thanks for the bugreport.
Comment 9 Fedora Update System 2013-09-22 20:30:10 EDT
gdb-7.6.50.20130731-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-09-24 19:00:40 EDT
gdb-7.5.1-42.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-09-24 19:02:29 EDT
gdb-7.6.1-41.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.