Bug 1004992 - Missing information about CopyTrans state "Approved" when copy from "Approved"
Missing information about CopyTrans state "Approved" when copy from "Approved"
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Component-CopyTrans (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Luke Brooker
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 20:31 EDT by David Mason
Modified: 2016-04-18 05:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:22:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-09-05 20:31:28 EDT
Description of problem:
In copytrans options, the UI indicates that translations will be copied as Translated if they do not match any blocking or downgrading conditions, but the actual behaviour is to copy as Approved in the case that the project requires review and the matching translation is in Approved state, and to only to copy as Translated when these conditions are not met. The UI should give an accurate indication of what the copytrans operation will do.

Version-Release number of selected component (if applicable):
3.0.2

How reproducible:
Always

Steps to Reproduce:
1. Sign in as admin or a project maintainer
2. Open a project that requires translation review
3. Copy Trans Options and observe the user interface

Actual results:
UI does not indicate that translations would ever be copied as 'Approved'

Expected results:
UI indicates that Approved translations will be copied as Approved.

Additional info:
Since this information is only relevant to projects that require translation review, the UI could leave out the information about Approved translations for non-review projects.
Comment 1 Damian Jansen 2014-07-28 22:28:04 EDT
Reviewed at 3.5.0-SNAPSHOT (git-server-3.4.2-201-ge0afdde)

UI indicates "If all previous steps have passed, copy as translated. Unless previously marked as fuzzy." which appears to be inaccurate.
Comment 2 Zanata Migrator 2015-07-30 21:22:42 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-468

Note You need to log in before you can comment on or make changes to this bug.