Bug 1005020 - Kernel 3.10 unable to resume from suspend
Kernel 3.10 unable to resume from suspend
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 23:30 EDT by Fred Wells
Modified: 2014-11-18 07:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-18 07:22:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (17.99 KB, text/plain)
2014-01-06 09:28 EST, Fred Wells
no flags Details
dmidecode output (16.22 KB, text/plain)
2014-01-06 09:29 EST, Fred Wells
no flags Details

  None (edit)
Description Fred Wells 2013-09-05 23:30:44 EDT
Description of problem:
System does not resume following suspend since kernel-3.10.x.

Version-Release number of selected component (if applicable):
kernel-3.10.10-200.fc19.x86_64
xorg-x11-drv-nouveau-1.0.9-1.fc19.x86_64
NVidia GeForce 9400 GT

How reproducible:
Every time

Steps to Reproduce:
1. Suspend to RAM
2. Press Power button to resume from suspend


Actual results:
System hangs.  No console, GUI or remote (ssh) access.  Requires reboot.  Following reboot, no evidence in syslog/dmesg of prior resume activity, indicating total and immediate system hang upon resume.

Expected results:
System should fully resume

Additional info:
This fails on both Fedora 18 and Fedora 19 under kernel-3.10.x.  Fedora 18 with kernel-3.9.x works fine.  Fails when using either nouveau or nvidia drivers.
Comment 1 Fred Wells 2013-09-05 23:48:59 EDT
Note that it only fails when suspending to ram.  Suspend to disk/resume works fine.
Comment 2 Josh Boyer 2013-09-18 16:37:06 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Fred Wells 2013-09-21 21:01:05 EDT
The problem still exists in kernel-3.11.1-200.fc19.x86_64.
Comment 4 Fred Wells 2013-12-15 23:36:01 EST
Haven't seen any movement on this.  Kernel now at 3.11.10-200.fc19 and still failing.
Comment 5 Justin M. Forbes 2014-01-03 17:10:30 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 6 Fred Wells 2014-01-05 00:17:52 EST
Problem still exists on 3.12.6-200.fc19.  Symptoms are unchanged.  As noted, this last worked with 3.9.x kernels and appears to have been introduced with 3.10 and has been unresolved since.
Comment 7 Michele Baldessari 2014-01-05 04:50:42 EST
Hi Fred,

can you attach the output of 'lspci -nvvv' and 'dmidecode'.
So at least we know what devices/what machines we are talking about?

Thanks,
Michele
Comment 8 Fred Wells 2014-01-06 09:28:11 EST
Created attachment 846121 [details]
lspci output

Requested lspci output attached.
Comment 9 Fred Wells 2014-01-06 09:29:00 EST
Created attachment 846123 [details]
dmidecode output

Requested dmidecode output.
Comment 10 Justin M. Forbes 2014-03-10 10:49:38 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.13.5-100.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 11 Fred Wells 2014-03-10 22:44:48 EDT
Problem still exists on 3.13.5-202.fc20.
Comment 12 Fred Wells 2014-04-19 00:38:12 EDT
Problem still exists on 3.13.10-200.fc20.
Comment 13 Justin M. Forbes 2014-05-21 15:29:56 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.14.4-100.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.
Comment 14 Justin M. Forbes 2014-11-13 11:02:47 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.17.2-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 21, and are still experiencing this issue, please change the version to Fedora 21.

If you experience different issues, please open a new bug report for those.
Comment 15 Fred Wells 2014-11-18 00:21:41 EST
3.17.2-200.fc20 fixes the reported issue, but unfortunately has yet another issue.  Upon resume the USB mouse is no longer working.
Comment 16 Josh Boyer 2014-11-18 07:22:50 EST
Please open a new bug for the USB issue.  We try and keep each bug report specific to one problem.

Note You need to log in before you can comment on or make changes to this bug.