Bug 1005023 - Jenkins build make haproxy process restart when hot_deploy marker is enabled
Jenkins build make haproxy process restart when hot_deploy marker is enabled
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 00:21 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 11:11:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-09-06 00:21:45 EDT
Description of problem:
When deploying a scalable app with hot_deploy marker by jenkins, the haproxy process will be restarted, but it will not restart when building without jenkins.

Version-Release number of selected component (if applicable):
INT(devenv_3749)

How reproducible:
always

Steps to Reproduce:
1. Create a scalable app with jenkins
rhc app create cpy27s0 python-2.7 -s --enable-jenkins
2. Check the PID of haproxy process
rhc ssh cpy27s0 'ps -ef |grep -w haproxy | grep -v grep'
3. Add hot_deploy marker and push
cd cpy27s0
touch .openshift/markers/hot_deploy
git add .; git commit -amp; git push
4. Check the PID of haproxy process again
rhc ssh cpy27s0 'ps -ef |grep -w haproxy | grep -v grep'

Actual results:
The PID of haproxy process is different at step 2 and step 4

Expected results:
The haproxy process should not be restarted after jenkins build

Additional info:
Comment 1 Mrunal Patel 2013-09-06 14:26:09 EDT
I was unable to reproduce the issue on latest devenv? Could you please retest?
Comment 2 chunchen 2013-09-09 02:48:18 EDT
@ Mrunal Patel 
I tried this issue on devenv_3758,also can not reproduce it now.
Comment 3 Mrunal Patel 2013-09-09 11:11:23 EDT
@chuchen,
I am closing this bug for now. Please re-open or create a new one if we see the issue again.

Thanks,
Mrunal

Note You need to log in before you can comment on or make changes to this bug.