Bug 1005036 - When using “-vga qxl” together with “-display vnc=:5” or “-display sdl” qemu displays pixel garbage
When using “-vga qxl” together with “-display vnc=:5” or “-display sdl” qemu...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
: 1018661 (view as bug list)
Depends On: 948717 1005037
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 01:20 EDT by Gerd Hoffmann
Modified: 2014-06-17 23:36 EDT (History)
20 users (show)

See Also:
Fixed In Version: qemu-kvm-1.5.3-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 948717
Environment:
Last Closed: 2014-06-13 09:18:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pixel garbage when using qxl (391.57 KB, image/png)
2013-12-18 22:31 EST, huiqingding
no flags Details

  None (edit)
Description Gerd Hoffmann 2013-09-06 01:20:11 EDT
+++ This bug was initially created as a clone of Bug #948717 +++

qemu-1.4.0-11.fc18.x86_64 from  https://fedoraproject.org/wiki/Virtualization_Preview_Repository

kernel-3.8.3-203.fc18.x86_64

qemu command line:

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 1 -drive file=./Fedora-19-Alpha-TC4-x86_64-netinst-test.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-19-Alpha-TC4-x86_64-netinst-test.iso.qcow2-output.log -name Fedora-19-Alpha-TC4-x86_64-netinst-test.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-19-Alpha-TC4/Fedora-19-Alpha-TC4-x86_64-netinst.iso -boot c -vga qxl -display vnc=:5 -net nic -net user,hostname=Fedora-19-Alpha-TC4-x86_64-netinst-test.iso.qcow2,hostfwd=tcp::5562-:22 -monitor stdio -usb

The above commandline has “-display vnc=:5”, the problem occurs
with “-display sdl” as well though.

The result is pixel garbage, see attached  screen shot.

When using “-vga std” or  “-vga cirrus” instead  of “-vga qxl” it works
fine, no pixel garbage.

--- Additional comment from Cole Robinson on 2013-04-14 21:55:06 CEST ---

I can reproduce with upstream. Grab F19 boot.iso here:

https://dl.fedoraproject.org/pub/alt/stage/19-Alpha-TC6/Fedora/x86_64/os/images/boot.iso

And run:

./x86_64-softmmu/qemu-system-x86_64 -enable-kvm -vga qxl -display sdl -cdrom ~/boot.iso -m 2048

Doing -device qxl works fine though. I also tried an F16 live cd I had hanging around and that worked fine, so maybe it's an F19 driver issue.

Alon, Gerd, thoughts?

--- Additional comment from Cole Robinson on 2013-05-28 01:01:01 CEST ---

Ping, any spice folks want to weigh in on this? Granted qxl->vnc shouldn't be a common setup, but people tend to try it out if hitting graphical issues and wanting to eliminate spice from the equation (for better or worse).

--- Additional comment from Steve Tyler on 2013-07-31 15:33:52 CEST ---

Confirming severe display corruption with the "-vga qxl" option.
With the "-vga std" option, there is no corruption.

By blindly clicking in the upper right corner, pressing the down-arrow four times, and pressing Enter twice, it is possible to power off the VM, if the corrupt display shows parts of the Welcome dialog.

Steps to reproduce:
$ qemu-kvm -m 4096 -cdrom ~/xfr/fedora/F19/Fedora-Live-Desktop-x86_64-19-1.iso -vga qxl

Version:
qemu-1.4.2-4.fc19.x86_64
kernel 3.10.3-300.fc19.x86_64

--- Additional comment from Jan Kratochvil on 2013-08-19 20:36:29 CEST ---

qemu-system-x86-1.4.2-5.fc19.x86_64
tigervnc-1.3.0-3.fc19.x86_64
/usr/bin/qemu-kvm -m 2048 -cdrom Fedora-19-x86_64-DVD.iso -boot d -vnc :10 -vga qxl

--- Additional comment from Mike FABIAN on 2013-08-31 08:07:40 CEST ---

The problem still exists with Fedora-20-Alpha-TC2-x86_64-netinst.iso
and qemu-1.6.0-5.fc19.x86_64
Comment 2 Gerd Hoffmann 2013-09-12 05:18:37 EDT
patches posted.
Comment 3 Miroslav Rezanina 2013-10-10 07:33:15 EDT
Fix included in qemu-kvm-1.5.3-9.el7
Comment 4 Gerd Hoffmann 2013-10-17 04:40:04 EDT
*** Bug 1018661 has been marked as a duplicate of this bug. ***
Comment 6 huiqingding 2013-12-18 22:29:22 EST
Reproduce this bug using the following version:
host kernel: kernel-3.10.0-63.el7.x86_64
qemu-kvm-1.5.3-8.el7.x86_64

1. Boot a guest with "-vga qxl -vnc :1"
# ionice -c 3 /usr/libexec/qemu-kvm -M q35 -nodefaults -cpu SandyBridge -enable-kvm -m 2048 -smp 8,sockets=2,cores=2,threads=2 -name rhel7 -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -drive file=/home/RHEL-7.0-20131127.1.qcow2_v3-bak,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,id=virtio-disk0  -vga qxl -vnc :1 -monitor stdio -spice port=5900,disable-ticketing  -qmp tcp:0:4445,server,nowait -netdev tap,id=hostnet0,ifname=guest14,script=/etc/ovs-ifup,downscript=/etc/ovs-ifdown,vhost=on -device virtio-net,netdev=hostnet0,mac=54:52:1b:35:3c:16,id=test

Actual results:
The screen has pixel garbage, see attached screen shot.


Additional info:
Start guest with "-vga std -vnc :1" and "-vga cirrus -vnc: 1" and not hit this bug.
Comment 7 huiqingding 2013-12-18 22:31:29 EST
Created attachment 838745 [details]
pixel garbage when using qxl
Comment 8 huiqingding 2013-12-18 22:37:00 EST
Reproduce this bug using the following version:
host kernel: kernel-3.10.0-63.el7.x86_64
qemu-kvm-1.5.3-24.el7.x86_64

1. Boot a guest with "-vga qxl -vnc :1"
# ionice -c 3 /usr/libexec/qemu-kvm -M q35 -nodefaults -cpu SandyBridge -enable-kvm -m 2048 -smp 8,sockets=2,cores=2,threads=2 -name rhel7 -uuid 6afa5f93-2d4f-420f-81c6-e5fdddbd1c83 -drive file=/home/RHEL-7.0-20131127.1.qcow2_v3-bak,if=none,id=drive-virtio-disk0,format=qcow2,serial=40c061dd-5d60-4fc5-865f-55db700407f0,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,drive=drive-virtio-disk0,id=virtio-disk0  -vga qxl -vnc :1 -monitor stdio -spice port=5900,disable-ticketing  -qmp tcp:0:4445,server,nowait -netdev tap,id=hostnet0,ifname=guest14,script=/etc/ovs-ifup,downscript=/etc/ovs-ifdown,vhost=on -device virtio-net,netdev=hostnet0,mac=54:52:1b:35:3c:16,id=test

Actual results:
The screen has no pixel garbage.


Additional info:
Start guest with "-vga std -vnc :1" and "-vga cirrus -vnc: 1" and the screen has no pixel garbage.

Based on the above result, I think this bug is fixed.
Comment 10 Ludek Smid 2014-06-13 09:18:39 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.