Bug 1005042 - Support DocBook 5 as input format
Support DocBook 5 as input format
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 915687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 01:49 EDT by Ruediger Landmann
Modified: 2013-12-18 21:46 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2013-09-06 01:49:17 EDT
Can we please support DocBook 5 as an input format alongside DocBook 4? This will make it much easier and cheaper to work with other open source documentation projects that have already made the move to DocBook 5.
Comment 2 HSS Product Manager 2013-09-08 21:57:31 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 3 Jeff Fearn 2013-09-17 02:34:14 EDT
This is in place in devel branch and can be tested.

Suggestions on alternative names for --dtdver accepted.
Comment 4 Jeff Fearn 2013-09-23 02:33:49 EDT
*** Bug 915687 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Capek 2013-10-16 11:41:42 EDT
Seems to work, not sure if my testing was sufficient:

rpm -q publican
publican-3.9.9-0.fc19.t6.noarch

publican create --lang en-US --name "Test_Book"

cd Test_Book; vi publican.cfg

Added dtdver: "5.0"

Then I went to 

http://www.docbook.org/tdg5/en/html/ch01.html#introduction-whats-new

I added two new tags to the book, personblurb and acknowledgments, and they were built with no problems even though their content was suppressed by Publican/brand.

I also added markup snippet described in:

"
In DocBook V5.0, this can be written as the following:

  1 <section xml:id="dir">
  2   <title>DIR command</title>
      <para>...</para>
  4 </section>
    
  6 <section xml:id="ls">
      <title>LS command</title>
  8   <para>This command is a synonym for
        <command linkend="dir">DIR</command> command.
 10   </para>
    </section>

"

Everything worked as expected so I guess the support is there. Moving to Verified

Note You need to log in before you can comment on or make changes to this bug.