Bug 1005074 - RSA usb disk can not be redirected to guest
RSA usb disk can not be redirected to guest
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 03:53 EDT by tingting zheng
Modified: 2013-09-10 09:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 09:07:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug info from virt-manager when redirect RSA usb (6.40 KB, text/plain)
2013-09-06 03:53 EDT, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2013-09-06 03:53:51 EDT
Created attachment 794606 [details]
debug info from virt-manager when redirect RSA usb

Description
RSA usb disk can not be redirected to guest

Version:
libvirt-1.1.1-3.el7.x86_64
virt-manager-0.10.0-3.el7.noarch
spice-glib-0.20-2.el7.x86_64
spice-gtk-0.20-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Use root user login system.
2. Launch virt-manager.
3. Open a guest,Click "Add Hardware"->"USB Redirection"->Type "Spice channel".
4. Open guest console,replug the RSA usb disk.
Error shows as below and the usb mouse of the host doesn't work anymore only after shutdown the guest.
Error info:
Could not redirect RSA SecurID (R) Authenticator [15e1:2007] at 6-2: Device is in use by another application

On host:
# lsusb
Bus 006 Device 004: ID 15e1:2007 RSA RSA SecurID (R) Authenticator

Actual results:
As description.

Expected results:
RSA usb disk can be auto redirected successfully.

Additional info:
Kingston usb disk can be redirected to guest successfully.
Attached virt-manager debug info.
Comment 2 David Jaša 2013-09-10 09:07:35 EDT
RSA stick is not an USB flash disk, it's a security token. The error message indicates that once the application currently accessing the device gives up its exclusivity, the device will be redirected just fine. Please reopen only if you are sure that the problem is indeed in USB redirection itself and not somewhere else in the system.

Note You need to log in before you can comment on or make changes to this bug.