Bug 100508 - RFE: make rhn-applet change green when first logging in
RFE: make rhn-applet change green when first logging in
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 20:12 EDT by Forrest
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 12:34:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The icon shows up as 'busy' while waiting for first checkin... (551 bytes, patch)
2003-08-27 18:49 EDT, Forrest
no flags Details | Diff

  None (edit)
Description Forrest 2003-07-22 20:12:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When first logging in, rhn-applet shows up as blue while it is waiting to first
login.  Once it finds outdated packages, the red exclamation shows up.  It seems
that it would be better to show the green connecting symbol when it says
"Waiting until first checkin...", instead of showing the blue check, and then
seeing a red exclamation.



Version-Release number of selected component (if applicable):
rhn-applet-2.0.9-1

How reproducible:
Always

Steps to Reproduce:
1.  Login and look at rhn-applet

Actual Results:  rhn-applet shows the blue check

Expected Results:  It should have shown the green connecting png
Comment 1 Forrest 2003-08-27 18:47:51 EDT
No one is brave enough?  Try this patch
Comment 2 Forrest 2003-08-27 18:49:07 EDT
Created attachment 94002 [details]
The icon shows up as 'busy' while waiting for first checkin...
Comment 3 Dee-Ann LeBlanc 2003-10-21 01:26:47 EDT
In test3, though, it happily changes to the blue check when in reality you
haven't had a chance to register with RHN yet. This means the user will be
thinking they're up to date unless they actually click on the applet icon, which
opens the RHN registration routine. Can we fix this?
Comment 4 Daniel Veillard 2003-10-21 05:34:17 EDT
With Fedora Core you don't have to register to get updates for example from
Yum repositories. I will check that there are sources defined, and if yes the
applet will be considered configured, if no, then the behaviour will need to
be changed.
W.r.t. changing the behaviour when loggin in, no there is a random delay 
introduced between the time of log-in and the time for the first check, that
need to be maintained. Turning the applet green is not proper, it means that
the applet is actively connecting to the server(s) and it is not the case
during that initial delay.

Daniel
Comment 5 Forrest 2003-10-21 12:13:21 EDT
I realize that there is a delay between first login and first checkin, and that
the green connecting icon is not proper.  However, I do not think that the blue
check mark is proper either, because it means that you are up-to-date.

I suggest using a different 'Waiting until first checkin' icon--something
neutral.  Maybe a clock/watch or a different colored check mark.
Comment 6 Daniel Veillard 2003-10-21 12:34:43 EDT
Well increasing the number of icons gets confusing too. The tooltip
allows to get that information already.
Changing the default behaviour is not a clear improvement, it would
lead to more confusion too. At this point, my take is that the status
quo is not that bad, and I prefer to deal with the couple of messages
about a possible improvement, rather than to deal with possibly far more
people confused by new state or new icons. This has to stay *very*
simple because it affects end-users.

Daniel

Note You need to log in before you can comment on or make changes to this bug.