Bug 1005094 - yum segfault with firefox 23.0.1-4.fc18 x86_64
yum segfault with firefox 23.0.1-4.fc18 x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 04:27 EDT by Harald Reindl
Modified: 2013-09-23 20:22 EDT (History)
4 users (show)

See Also:
Fixed In Version: firefox-23.0.1-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 22:04:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-09-06 04:27:33 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1004062

i did not expect that this package hits updates-testing after my bugreport for yum which i now changed to "rpm" - what the hell does the FF package while others are updated fine all the time?

[root@srv-rhsoft:/var/cache/yum/updates-testing/packages]$ rpm -Uvh firefox-23.0.1-4.fc18.x86_64.rpm
BDB2053 Freeing read locks for locker 0xcc3: 17141/140182230734912
BDB2053 Freeing read locks for locker 0xcc5: 17141/140182230734912
Segmentation fault
[root@srv-rhsoft:/var/cache/yum/updates-testing/packages]$ rpm -Uvh firefox-23.0.1-4.fc18.x86_64.rpm
BDB2053 Freeing read locks for locker 0xcce: 17147/139655766075456
BDB2053 Freeing read locks for locker 0xcd0: 17147/139655766075456
Segmentation fault
Comment 1 Harald Reindl 2013-09-08 10:07:55 EDT
*unpush this dmaned package from updates-testing* and the next time you build anything *try to install it on your own machine* before push it anywhere - unbelieveable

if you follow https://bugzilla.redhat.com/show_bug.cgi?id=1004062 you realize that the firefox package is broken and that rpm results in a sehfault is the rsult of it and a different story
Comment 2 Panu Matilainen 2013-09-08 11:33:43 EDT
Here's a suggested fix, ie conditionalize the entire %pretrans, not just its body. Rpm needs to be fixed to not crash on an empty <lua> scriptlet body but an empty %pretrans -p <lua> simply does not make any sense in any situation:

diff --git a/firefox.spec b/firefox.spec
index f4aecc6..9db8f9c 100644
--- a/firefox.spec
+++ b/firefox.spec
@@ -348,8 +348,8 @@ sed -i -e "s/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/
 #---------------------------------------------------------------------
 
 # Moves defaults/preferences to browser/defaults/preferences in Fedora 19+
-%pretrans -p <lua>
 %if 0%{?fedora} >= 19
+%pretrans -p <lua>
 require 'posix'
 require 'os'
 if (posix.stat("%{mozappdir}/browser/defaults/preferences", "type") == "link")
Comment 3 Jan Horak 2013-09-09 02:51:00 EDT
(In reply to Harald Reindl from comment #1)
> *unpush this dmaned package from updates-testing* and the next time you
> build anything *try to install it on your own machine* before push it
> anywhere - unbelieveable
> 
> if you follow https://bugzilla.redhat.com/show_bug.cgi?id=1004062 you
> realize that the firefox package is broken and that rpm results in a
> sehfault is the rsult of it and a different story

Calm down please. Package went only to updates-testing and this channel is for testing only. It didn't go to stable. I simply don't have F18 anymore and I can't test package for all Fedoras. That's why we have update-testing repository and update tool with karma feedback.
Comment 4 Harald Reindl 2013-09-09 03:58:14 EDT
> I simply don't have F18 anymore

unacceptable behavior in case of a maintainer with a @redhat.com address
virtualization exists

> Package went only to updates-testing and this channel is for testing only

i know that, and people having enabled updates-testing like me are fucked up everytime they type "yum update" because a maintainer does "build and forget"
Comment 5 Fedora Update System 2013-09-09 08:30:32 EDT
firefox-23.0.1-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firefox-23.0.1-5.fc18
Comment 6 Fedora Update System 2013-09-09 08:30:45 EDT
firefox-23.0.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firefox-23.0.1-5.fc19
Comment 7 Fedora Update System 2013-09-09 08:30:58 EDT
firefox-23.0.1-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firefox-23.0.1-5.fc20
Comment 8 Fedora Update System 2013-09-09 12:18:50 EDT
Package firefox-23.0.1-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firefox-23.0.1-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16130/firefox-23.0.1-5.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-09-10 22:04:40 EDT
firefox-23.0.1-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-09-22 20:28:01 EDT
firefox-23.0.1-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-09-23 20:22:36 EDT
firefox-23.0.1-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.