Bug 1005110 - ClassLoader memory leak with EJB Asynchronous invocations
ClassLoader memory leak with EJB Asynchronous invocations
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB (Show other bugs)
6.1.0,6.0.1,6.1.1
Unspecified Unspecified
unspecified Severity unspecified
: ER1
: EAP 6.2.0
Assigned To: David M. Lloyd
Jan Martiska
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 05:05 EDT by Jaikiran Pai
Modified: 2014-05-26 21:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In some situations, asynchronous EJB calls could result in the deployment's classloader being "leaked". This occurred because the execute method could lead to new thread creation. When this occurs the new thread assigns itself the context classloader of the parent thread, which would be the classloader of the deployment. To prevent this the Thread Context Classloader (TCCL) is set to `null` before the execute method is invoked, and then restored afterwards. Asynchronous EJB calls can no longer result in deployment classloader leaks.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaikiran Pai 2013-09-06 05:05:56 EDT
Using asynchronous EJB call via @Asynchronous annotation leads to class loader leak.

This was reported in WildFly upstream https://issues.jboss.org/browse/WFLY-1375 and was fixed there. The bug is applicable to EAP 6 too.
Comment 2 Jan Martiska 2013-09-18 04:29:49 EDT
Verified in EAP 6.2.0.ER1.
Comment 8 Dimitris Andreadis 2013-10-24 14:28:00 EDT
Assigning jpai@redhat.com EJB issues to david.lloyd@redhat.com. Please re-assign to Cheng or others as needed.

Note You need to log in before you can comment on or make changes to this bug.