Bug 1005133 - kolourpaint-4.11.1-1 has no correct tools icons
kolourpaint-4.11.1-1 has no correct tools icons
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.11
  Show dependency treegraph
 
Reported: 2013-09-06 05:39 EDT by carasin
Modified: 2013-09-15 19:05 EDT (History)
11 users (show)

See Also:
Fixed In Version: kde-workspace-4.11.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 13:21:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kolourpaint screenshot (62.65 KB, image/png)
2013-09-06 05:40 EDT, carasin
no flags Details
krusader screenshot (122.66 KB, image/png)
2013-09-06 05:41 EDT, carasin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 324574 None None None Never
KDE Software Compilation 324599 None None None Never

  None (edit)
Description carasin 2013-09-06 05:39:52 EDT
Description of problem:

I've updated KDE  up to 4.11.1-1 from kde-unstable repo (http://fedoraproject.org/wiki/SIGs/KDE/Testing). And now kolourpaint has no correct tools icons (see the first screenshot). Krusader has the same issue (see the second screenshot). Everything was well before the update.
_______________________

Version-Release number of selected component (if applicable):

kde-4.11.1-1
_______________________

How reproducible:

always
_______________________

Steps to Reproduce:

1. update KDE up to 4.11.1-1 from kde-unstable repo
2. launch kolourpaint or/and krusader
_______________________

Actual results:

kolourpaint has no correct tools icons (and krusader too)
_______________________

Expected results:

all icons are OK
_______________________

Additional info:

krusader version is the same (it was not updated)
Comment 1 carasin 2013-09-06 05:40:50 EDT
Created attachment 794627 [details]
kolourpaint screenshot
Comment 2 carasin 2013-09-06 05:41:25 EDT
Created attachment 794628 [details]
krusader screenshot
Comment 3 Vasiliy Glazov 2013-09-06 05:51:00 EDT
I confirm it.
Comment 4 Rex Dieter 2013-09-06 08:17:57 EDT
me too, anyone up for filing a bug upstream?
Comment 5 Rex Dieter 2013-09-06 08:24:39 EDT
Downgrading to kolourpaint-4.10.5 doesn't help, it is likely some kdelibs or kde-runtime change methinks.
Comment 6 carasin 2013-09-06 15:40:20 EDT
(In reply to Rex Dieter from comment #5)
> Downgrading to kolourpaint-4.10.5 doesn't help, it is likely some kdelibs or
> kde-runtime change methinks.

Kolourpaint is not the issue root because Krusader suffers too.
Comment 7 carasin 2013-09-06 15:40:53 EDT
(In reply to Rex Dieter from comment #4)
> me too, anyone up for filing a bug upstream?

Done:
https://bugs.kde.org/show_bug.cgi?id=324599
Comment 8 Rex Dieter 2013-09-09 12:52:45 EDT
upstream fix applied to downstream packaging kde-workspace-4.1.1-2
Comment 9 Rex Dieter 2013-09-09 13:21:40 EDT
make that kde-workspace-4.11.1-2 (confirmed fixed)
Comment 10 carasin 2013-09-09 14:13:18 EDT
I confirm that the update fixes this issue. Thanks, Rex.
Comment 11 Kevin Kofler 2013-09-13 17:26:46 EDT
Reassigning for the record. Good work, Rex!

Note You need to log in before you can comment on or make changes to this bug.