Bug 1005141 - dumping to NFS fails when the netdev ifcfg name is not same as itself
dumping to NFS fails when the netdev ifcfg name is not same as itself
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Baoquan He
Qiao Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 05:48 EDT by Xiaoqing Wei
Modified: 2015-07-22 02:00 EDT (History)
8 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-286.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:00:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2013-09-06 05:48:00 EDT
Description of problem:

dumping to NFS fails if the netdev cfg name is not same as itself

# brctl show switch
bridge name	bridge id		STP enabled	interfaces
switch		8000.b8ac6f3af4f2	no		eth1

# cat /etc/sysconfig/network-scripts/ifcfg-br0 
DEVICE=switch
BOOTPROTO=dhcp
ONBOOT=yes
TYPE=Bridge
DELAY=0
STP=0
#MTU=9216
IPV6INIT=no
USERCTL=no


Version-Release number of selected component (if applicable):
kexec-tools-2.0.0-245.el6.x86_64
busybox-1.15.1-15.el6.x86_64


How reproducible:

100%
Steps to Reproduce:
1.
2.
3.

Actual results:
kdump fails,
============================ extract the kdump initrafs
#cat iface_to_activate 
switch

# cat ifcfg-switch 
BUS_ID=""

it's empty

Expected results:
dumpping should success

Additional info:
if mv /etc/sysconfig/network-scripts/ifcfg-br0 /etc/sysconfig/network-scripts/ifcfg-switch


then dump would success.
Comment 3 Baoquan He 2013-09-06 21:49:29 EDT
Hi,

Since this is a rhel6.5 bug, did you tried the latest version, e.g Release 2.0.0-267.

Baoquan
Thanks
Comment 4 Xiaoqing Wei 2013-09-07 02:40:48 EDT
(In reply to Baoquan He from comment #3)
> Hi,
> 

Hi Baoquan,

> Since this is a rhel6.5 bug, did you tried the latest version, e.g Release
> 2.0.0-267.
> 


Yes, same issue.
and RHEL.7 dont have such issue,
kexec-tools-2.0.4-8.el7.x86_64

Regards,
Xiaoqing.
Comment 5 Xiaoqing Wei 2013-09-07 03:28:28 EDT
# service kdump restart
Stopping kdump:                                            [  OK  ]
No kdump initial ramdisk found.                            [WARNING]
Rebuilding /boot/initrd-2.6.32-414.el6.x86_64kdump.img
cp: cannot stat `/etc/sysconfig/network-scripts/ifcfg-switch': No such file or directory
/sbin/mkdumprd: line 1006: /tmp/initrd.gWAtqO/etc/ifcfg-switch: No such file or directory
Starting kdump:                                            [  OK  ]
# rpm -q kexec-tools
kexec-tools-2.0.0-267.el6.x86_64
Comment 6 RHEL Product and Program Management 2013-10-13 22:20:54 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 errata-xmlrpc 2015-07-22 02:00:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1271.html

Note You need to log in before you can comment on or make changes to this bug.