Bug 1005147 - Cannot add ssh keys
Cannot add ssh keys
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 06:06 EDT by Joachim Backes
Modified: 2014-09-10 03:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 03:48:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Window if I try ty add a openssh key (40.80 KB, image/png)
2013-09-06 06:06 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2013-09-06 06:06:22 EDT
Created attachment 794637 [details]
Window if I try ty add a openssh key

Description of problem:
I start seahorse and try to add an openssh key, but seahorse only presents a window for creating a password keyring. Still no change after having created the SSH key ring: I'm continously asked for the creation of a new keyring.

Version-Release number of selected component (if applicable):
seahorse-3.9.91-1.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1.start seahorse
2.
3.

Actual results:
I'm not prompted for a remote host ssh key

Expected results:


Additional info:
Comment 1 Hans de Goede 2013-09-06 06:09:45 EDT
Fixing up component ...
Comment 2 Joachim Backes 2013-09-25 02:31:03 EDT
Still the same flaw with seahorse-3.10.0-1.fc20.x86_64
Comment 3 Joachim Backes 2013-11-13 03:49:05 EST
Trying seahorse-3.10.1-1.fc20.x86_64: Adding a secure shell key fails with some weird error popup window:

------------------------------------------
Couldn't generate Secure shell key:
Generating public/private rsa key pair.
(null) already exists.
Overwrite (y/n)? 
------------------------------------------
No chance to enter yes or no!


Stderr output:

----------------  snip ------------------------------------
** Message: SSH command failed: (1)
** Message: SSH error: Generating public/private rsa key pair.
(null) already exists.
Overwrite (y/n)? 
------------------ snip ------------------------------------
Comment 4 Joachim Backes 2014-01-21 08:54:12 EST
Got rid of the described problem by installing seahorse-3.10.2-1.fc20.x86_64 :-)

Note You need to log in before you can comment on or make changes to this bug.