Bug 1005164 - Add code for syncenv_destroy() and clean up syncenv_new()
Add code for syncenv_destroy() and clean up syncenv_new()
Status: CLOSED DUPLICATE of bug 1093594
Product: GlusterFS
Classification: Community
Component: libglusterfsclient (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: santosh pradhan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 06:41 EDT by santosh pradhan
Modified: 2014-09-21 18:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-10 06:37:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description santosh pradhan 2013-09-06 06:41:33 EDT
Description of problem:

1. syncenv_destroy() does not have any code i.e. empty routine. Which should have free()d the syncenv structure allocated in syncenv_new().

2. In syncenv_new(), procmax was not validated for negative value.

3. syncenv_new(): pthread_create() failure still returns the valid syncenv structure allocated instead of NULL.


Version-Release number of selected component (if applicable):


How reproducible:

N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-09-06 07:29:03 EDT
REVIEW: http://review.gluster.org/5838 (libglusterfs: clean up for syncenv_new/destroy()) posted (#1) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 2 Anand Avati 2013-09-11 03:23:20 EDT
REVIEW: http://review.gluster.org/5838 (libglusterfs: clean up for syncenv_new/destroy()) posted (#2) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 3 Anand Avati 2013-09-12 04:40:33 EDT
REVIEW: http://review.gluster.org/5838 (libglusterfs: clean up for syncenv_new/destroy()) posted (#3) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 4 Anand Avati 2013-09-12 04:48:29 EDT
REVIEW: http://review.gluster.org/5838 (libglusterfs: clean up for syncenv_new/destroy()) posted (#4) for review on master by Santosh Pradhan (spradhan@redhat.com)
Comment 5 santosh pradhan 2014-06-10 06:37:51 EDT

*** This bug has been marked as a duplicate of bug 1093594 ***

Note You need to log in before you can comment on or make changes to this bug.