Bug 1005177 - No admin bar available for Business Dashboards
No admin bar available for Business Dashboards
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity high
: ER4
: 6.0.0
Assigned To: David Gutierrez
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 07:20 EDT by David Gutierrez
Modified: 2014-08-06 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dashbuilder without admin capabilities (134.27 KB, image/png)
2013-09-06 07:20 EDT, David Gutierrez
no flags Details

  None (edit)
Description David Gutierrez 2013-09-06 07:20:51 EDT
Created attachment 794668 [details]
Dashbuilder without admin capabilities

Description of problem:

The "Business Dashboards" link opens up a separated browser window but without the ability to create new dashboards.

Version-Release number of selected component (if applicable):

6 ER2 

How reproducible:

Always.

Steps to Reproduce:
1. Sign in as an admin user.
2. Click on Home>Process&Task dashboards 
3. Click on Home>Business Dashboards 

Actual results:

A new browser window is opened but without the ability to manage the list of dashboards available. The top administration bar is not displayed.

Expected results:

The top admin bar should be there. 

Additional info:
Comment 2 Pedro Zapata 2013-09-06 10:12:51 EDT
The problem is that the bar is not displayed is coming from embedded mode. It's apparently storing a property in the session, and if you after that you can't see the bar.

The 'Business Dashboard' option also always take you to the latest page. If it's your first login you get the dashboard homes. If you previously enter the 'Process Dashboard' option, then you get the same screen.

This behaviour is not good enough. Embedded mode should only happen when the dashboard is shown inside another page. The link in 'Business dashboard' should lead you to the dashboards home in not embedded mode.


If you login with a new session directly into the /dashbuilder it works well.
Comment 3 David Gutierrez 2013-09-10 11:23:09 EDT
Now the embedded mode is only enabled when passing the following parameter in the URL: "embedded=true". Once embedded, all the links generated within the app contains the "embedded=true" (via URL-rewriting). to disable the embedded mode we just have to invoke on a URL without that parameter which it's just the case of the "Business dashboards" link.   

Github commit (master): https://github.com/droolsjbpm/dashboard-builder/commit/376ac063bc8457d92b521fe2ec9ee375a89f903d

Github commit (6.0.x): https://github.com/droolsjbpm/dashboard-builder/commit/fe17301a523257e314b423adcf15f6f4be8b3085
Comment 5 Marek Baluch 2013-10-21 03:31:06 EDT
Verified on ER4.

Note You need to log in before you can comment on or make changes to this bug.