This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005183 - cluster wide lock not released when originating glusterd dies
cluster wide lock not released when originating glusterd dies
Status: CLOSED DUPLICATE of bug 969461
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 07:33 EDT by Avra Sengupta
Modified: 2014-07-11 14:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-11 14:22:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2013-09-06 07:33:00 EDT
Description of problem:
Most gluster commands takes a cluster wide lock, before proceeding to staging process. And after the commit stage, the cluster is unlocked. But if in between the node, from which the command was executed goes down, the lock is not released, and the whole cluster stays in a lockdown stage.


Version-Release number of selected component (if applicable):


How reproducible:
Everytime


Steps to Reproduce:
1. Attach gdb to a glusterd process on one of the nodes, and put a breakpoint.
2. Run a gluster volume command from any other node.
3. While the process is waiting on the breakpoint, kill the node from which the command was given.

Actual results:
The whole cluster remains in a lockdown


Expected results:
The cluster should recover itself from the locked stage


Additional info:
Comment 1 Anand Avati 2013-09-06 07:46:03 EDT
REVIEW: http://review.gluster.org/5839 (glusterd: Release cluster locks on receiving rpc disconnect) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2013-09-11 03:44:29 EDT
REVIEW: http://review.gluster.org/5839 (glusterd: Release cluster locks on receiving rpc disconnect) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Anand Avati 2013-09-11 03:50:33 EDT
REVIEW: http://review.gluster.org/5839 (glusterd: Release cluster locks on receiving rpc disconnect) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2013-09-13 10:44:43 EDT
REVIEW: http://review.gluster.org/5839 (glusterd: Release cluster locks on receiving rpc disconnect) posted (#4) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 5 Avra Sengupta 2013-12-06 01:19:43 EST
This fix has already made it upstream as part of http://review.gluster.org/#/c/6003/
Comment 6 Niels de Vos 2014-07-11 14:22:38 EDT

*** This bug has been marked as a duplicate of bug 969461 ***

Note You need to log in before you can comment on or make changes to this bug.