Bug 1005186 - Unable to undefine attribute enable-welcome-root for virtual server via CLI
Unable to undefine attribute enable-welcome-root for virtual server via CLI
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.2.0
Assigned To: Chao Wang
Radim Hatlapatka
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 07:36 EDT by Radim Hatlapatka
Modified: 2013-12-15 11:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:20:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-09-06 07:36:45 EDT
Description of problem:
Instead of attribute enable-welcome-root being undefined it is set to a default value

Version-Release number of selected component (if applicable):
EAP 6.1.1

How reproducible: always


Steps to Reproduce:
1. /subsystem=web/virtual-server=default-host:undefine-attribute(name=enable-welcome-root)
2. /subsystem=web/virtual-server=default-host:read-attribute(include-defaults=false, name=enable-welcome-root)


Actual results:

false

Expected results:

undefined


Additional info:
read-resource-description shows that this attribute is nillable
Comment 1 Chao Wang 2013-09-27 04:49:56 EDT
This because that SimpleAttribute 'enable-welcome-root' is nillable but has a default value set to false and WriteEnableWelcomeRoot considers all non-true value as a false value, Thus, user can't undefine it.

I have prepared a fix on https://github.com/soul2zimate/jboss-eap/commit/848349cec769600e7be012b9bfc2ca759a41b367

However, I wonder if it's intended to work like that? if true, we only need to revise attribute description to non-nullable and accept false as default value.
Comment 3 Radim Hatlapatka 2013-11-04 07:34:44 EST
Verified in EAP 6.2.0.ER7

Note You need to log in before you can comment on or make changes to this bug.