Bug 100519 - coreutils doesn't support ACLs
Summary: coreutils doesn't support ACLs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: coreutils (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 02:11 UTC by Travers Carter
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 15:31:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Apply Makefile.in changes to Makefile.am (1.04 KB, patch)
2003-07-23 02:14 UTC, Travers Carter
no flags Details | Diff

Description Travers Carter 2003-07-23 02:11:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
the core utils package does not support ACLs (cp/mv don't preserve them and ls -l doesn't show '+' on permissions when ACLs are present), the patches are in the package, and applied, but configure is not regenerated to pick up the ACL options.

In order to get the patches to actually compile I had to add autoreconf --force before %configure in the spec file and apply the attached patch.

I think the AM_CONFIG_HEADER/AC_CONFIG_HEADERS thing is just to do with my version of automake?  But the coreutils-4.5.2-dumbterm.patch modifies src/Makefile.in which is regenerated by autoreconf, so I had to patch src/Makefile.am instead to actually include -ltermcap


Version-Release number of selected component (if applicable):
5.0-6

How reproducible:
Always

Steps to Reproduce:
rpmbuild --rebuild coreutils-5.0-6.src.rpm



Actual Results:  coreutils is built without ACL support despite having acl & attr devel packages.


Expected Results:  coreutils should support ACLs (mv/cp should preserve them and ls shoud show at '+' after file permissions where ACLs are present

Additional info:

The same problem seems to exist in older coreutils (4.x) packages, ACL support patches are present and applied, but since configure isn't regenerated the support is never built.

The ACL filesystem is XFS, installed from SGI's XFS installer CD for RH9, it is not a standard kernel, it is the XFS patched version.
The coreutils package is the standard RawHide version though.

Comment 1 Travers Carter 2003-07-23 02:14:56 UTC
Created attachment 93069 [details]
Apply Makefile.in changes to Makefile.am

I think the AC_CONFIG_HEADERS/AM_CONFIG_HEADER change is just needed because my
version of automake doesn't match? 

The src/Makefile.am change is needed to build with -ltermcap after autoreconf
is run, since the original change from the coreutils-4.5.2-dumbterm patch are
overwritten by autoreconf

Comment 2 Tim Waugh 2003-08-08 15:31:01 UTC
Fixed in current rawhide.

Comment 3 Nicholas Miell 2003-11-04 22:22:06 UTC
This is broken again in coreutils 5.0-24.

cp, ls, dir, and vdir link against libacl.so.1, but they don't
actually import any acl_* functions (and nothing ACL-related works).

mv doesn't link against libacl.so.1 at all.

So, it looks like something in the Makefiles/configure script is broken.

Being a mere mortal, I can't reopen this bug.

Comment 4 Nicholas Miell 2003-11-09 00:18:18 UTC
Ok, bug #106141 is what broke this.


Note You need to log in before you can comment on or make changes to this bug.