Bug 1005215 - glusterd: Crashes when tried to set quorum ratio
glusterd: Crashes when tried to set quorum ratio
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: krishnan parthasarathi
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 08:58 EDT by Sachidananda Urs
Modified: 2015-11-03 18:05 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.32rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-09-06 08:58:33 EDT
Description of problem:

Run the command:

gluster volume set all cluster.server-quorum-ratio 80

glusterd crashes

Version-Release number of selected component (if applicable):
glusterfs 3.4.0.31rhs built on Sep  5 2013 08:23:16


How reproducible:
Always


Actual results:


Expected results:


Additional info:

[2013-09-06 07:58:24.191347] I [glusterd-handler.c:1073:__glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2013-09-06 07:59:44.240158] W [xlator.c:137:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.4.0.31rhs/xlator/configuration.so: cannot open shared object file: No such file or directory
[2013-09-06 07:59:44.240271] W [xlator.c:137:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.4.0.31rhs/xlator/configuration.so: cannot open shared object file: No such file or directory
[2013-09-06 07:59:44.279579] W [xlator.c:137:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.4.0.31rhs/xlator/configuration.so: cannot open shared object file: No such file or directory
[2013-09-06 07:59:44.279627] W [xlator.c:137:xlator_volopt_dynload] 0-xlator: /usr/lib64/glusterfs/3.4.0.31rhs/xlator/configuration.so: cannot open shared object file: No such file or directory
[2013-09-06 08:34:42.748621] W [glusterd-op-sm.c:3104:glusterd_op_modify_op_ctx] 0-management: op_ctx modification failed
[2013-09-06 08:34:42.765401] I [glusterd-handler.c:3498:__glusterd_handle_status_volume] 0-management: Received status volume req for volume pure_gold
[2013-09-06 08:51:46.071959] E [glusterd-syncop.c:890:gd_stage_op_phase] 0-management: Staging of operation 'Volume Set' failed on localhost : Not a valid option for single volume
pending frames:
frame : type(0) op(0)

patchset: git://git.gluster.com/glusterfs.git
signal received: 11
time of crash: 2013-09-06 08:51:51configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.4.0.31rhs
/lib64/libc.so.6[0x3ba3632960]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(+0x3f53d)[0x7f3b1f62153d]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(glusterd_op_stage_validate+0x25b)[0x7f3b1f622feb]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(gd_stage_op_phase+0x9a)[0x7f3b1f673f7a]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(gd_sync_task_begin+0x272)[0x7f3b1f6753f2]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(glusterd_op_begin_synctask+0x3b)[0x7f3b1f67557b]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(__glusterd_handle_set_volume+0x49c)[0x7f3b1f608c5c]
/usr/lib64/glusterfs/3.4.0.31rhs/xlator/mgmt/glusterd.so(glusterd_big_locked_handler+0x3f)[0x7f3b1f6067bf]
/usr/lib64/libglusterfs.so.0(synctask_wrap+0x12)[0x7f3b230c0662]
/lib64/libc.so.6[0x3ba3643bb0]

Will attach sosreport soon.
Comment 2 Sachidananda Urs 2013-09-07 04:44:19 EDT
Verified on:

[root@boggs ~]# gluster --version
glusterfs 3.4.0.32rhs built on Sep  6 2013 10:26:11

[root@boggs ~]# gluster volume set all server-quorum-ratio 70
volume set: success
Comment 3 Scott Haines 2013-09-23 18:25:13 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.