Bug 1005232 - Update Fedora 20 release name to Heisenbug
Update Fedora 20 release name to Heisenbug
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-09-06 09:31 EDT by Jaroslav Reznik
Modified: 2013-09-13 23:08 EDT (History)
5 users (show)

See Also:
Fixed In Version: fedora-release-20-0.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 23:08:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2013-09-06 09:31:34 EDT
Description of problem: Fedora 20 release name voting ended and Heisenbug is the winner... https://admin.fedoraproject.org/voting/results/relnamef20

Steps to Reproduce:
1. cat /etc/fedora-release

Actual results:
Fedora release 20 (Null)

Expected results:
Fedora release 20 (Heisenbug)

Potential Alpha blocker - "Any component which prominently identifies a Fedora release version number, code name or milestone (Alpha, Beta, Final) must do so correctly."
Comment 1 Fedora Update System 2013-09-06 10:34:32 EDT
fedora-release-20-0.7 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedora-release-20-0.7
Comment 2 Fedora Update System 2013-09-06 13:26:30 EDT
Package fedora-release-20-0.7:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-release-20-0.7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15966/fedora-release-20-0.7
then log in and leave karma (feedback).
Comment 3 Jan Sedlák 2013-09-09 08:06:25 EDT
It works in TC5:

[user@localhost ~]$ cat /etc/redhat-release 
Fedora release 20 (Heisenbug)
Comment 4 Andre Robatino 2013-09-09 08:10:05 EDT
(In reply to Jan Sedlák from comment #3)
> It works in TC5:
> 
> [user@localhost ~]$ cat /etc/redhat-release 
> Fedora release 20 (Heisenbug)

That's from updates-testing. The 20 Alpha TC5 DVD has fedora-release-20-0.6. I don't know what the Lives/Spins have.
Comment 5 Kamil Páral 2013-09-09 12:20:52 EDT
Discussed at 2013-09-09 blocker review meeting [1]. This has been accepted as an Alpha blocker, because it violates the following F20 alpha release criterion: "Any component which prominently identifies a Fedora release version number, code name or milestone (Alpha, Beta, Final) must do so correctly." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-09/
[2] https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Self-identification
Comment 6 Tim Flink 2013-09-11 14:41:51 EDT
did a gnome install from f20 alpha RC1 dvd, release name is set correctly in /etc/fedora-release

[tflink@localhost ~]$ cat /etc/fedora-release 
Fedora release 20 (Heisenbug)

moving to verified
Comment 7 Fedora Update System 2013-09-13 23:08:53 EDT
fedora-release-20-0.7 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.