Bug 1005263 - Updating consumer groups
Updating consumer groups
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: consumers (Show other bugs)
Master
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 10:29 EDT by Chase
Modified: 2015-02-28 16:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:58:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 370 None None None Never

  None (edit)
Description Chase 2013-09-06 10:29:28 EDT
Description of problem:
We have a few consumers setup (CentOS).  We are able to update the individual consumers without error.  We grouped several like consumers together into a consumer group and tried to update the consumer group together.  That fails and appears to be a bug in how the CLI is parsing the data it gets back from the server.

Version-Release number of selected component (if applicable):


How reproducible: Very.  Every time.

Steps to Reproduce:
1. pulp-admin rpm consumer group package update --consumer-group-id=it-nonprod --names='*'
"An unexpected error has occurred. More information can be found in the client
log file ~/.pulp/admin.log."
Consumer logs show nothing on the consumers in the group.  Gopher logs show that responses are being sent.

Actual results:
2013-09-06 10:27:51,241 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/client/extensions/core.py", line 478, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.6/site-packages/okaara/cli.py", line 966, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.6/site-packages/pulp/client/extensions/extensions.py", line 224, in execute
    return self.method(*arg_list, **clean_kwargs)
  File "/usr/lib/pulp/admin/extensions/rpm_admin_consumer/consumer_group_package.py", line 183, in run
    self.update(consumer_group_id, units, options)
  File "/usr/lib/pulp/admin/extensions/rpm_admin_consumer/consumer_group_package.py", line 195, in update
    msg = _('Update task created with id [%s]') % task.task_id
AttributeError: 'list' object has no attribute 'task_id'

Expected results:
Expected it to attempt to update all consumers in the consumer group
Comment 1 Chase 2013-09-06 11:45:21 EDT
I downgraded the severity as more testing shows that the updates are actually happening on the client ends.

What's failing is the pulp-admin application.

pulp-admin rpm consumer group package update --consumer-group-id=it-nonprod --names='*'

That command properly sets up the different tasks and they run, however, when the command waits for a response from the servers, it treats that response as if it's one singular response when it's a list of responses (Tasks).  So, as it tries to get the task_id, it fails because it's asking a list for a property instead of the first element in the list for that property.

pulp-admin tasks list

That command properly shows the tasks moving along to completion.
Comment 2 Brian Bouterse 2015-02-28 16:58:27 EST
Moved to https://pulp.plan.io/issues/370

Note You need to log in before you can comment on or make changes to this bug.