Bug 10053 - /etc/mtab lock file causes hang at boot time
/etc/mtab lock file causes hang at boot time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-08 06:46 EST by martin
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 12:26:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description martin 2000-03-08 06:46:05 EST
The problem occurs with initscripts-4.54-1, but doesn't seem to be
fixed in 4.70-1.

Boot problem: The system didnt come up, not even in single-user mode.
(Btw: where is rescue.img in RedHat 6.1??? The docs say it's there, but it
isn't!!!).

The reason was an inexperienced user who had edited /etc/mtab instead of
/etc/fstab for entering mount points. The editor created a file
/etc/mtab[tilde] (sorry, I cant type the tilde in this window),
which, for some reason, is used as lockfile for /etc/mtab access.

The hang occurs after remounting root read-write, when the lines

# Enter root and /proc into mtab.
mount -f /
mount -f /proc

are executed. Later in the script, the lock file is removed, but that's
too late. If it was removed before executing the above lines, the
problem wouldn't occur.

Although editing /etc/mtab is admittedly stupid, I guess it can happen
that inexperienced users confuse fstab and mtab, so this little workaround
would improve stability.

Martin Wilck <martin@tropos.de>
Institute for Tropospheric Research, Permoserstr. 15, D-04318 Leipzig,
Germany
Tel. +49-341-2352151 / Fax +49-341-2352361
Comment 1 Bill Nottingham 2000-03-20 12:13:59 EST
This is fixed as of the current rawhide initscripts.

Note You need to log in before you can comment on or make changes to this bug.