Bug 1005304 - Current package 3.1.1 has a fairly significant bug that 3.2.4 fixes
Current package 3.1.1 has a fairly significant bug that 3.2.4 fixes
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: puppet (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 11:49 EDT by Paul Houghton
Modified: 2014-12-01 08:00 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-08 11:03:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
paul4hough: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Paul Houghton 2013-09-06 11:49:07 EDT
Description of problem:
I installed puppet via 'yum install puppet' on a fairly fresh fedora 19 system from 'updates' default repository. This installed 3.1.1 which has a bug that has been resolved by installing via the puppetlabs-products repo which installs version 3.2.4

Here is a link to the issue I had reported to puppet: 
https://github.com/rodjek/rspec-puppet/issues/117

Version-Release number of selected component (if applicable):
3.1.1

How reproducible:
Every time.

Steps to Reproduce:
1. Please see my link, all details are there:

Actual results:
Test fails with cryptic message.

Expected results:
Test to pass.

Additional info:
A simple upgrade of the repository to version 3.2.4 should resolve the problem.
Comment 1 Sam Kottler 2013-09-06 13:05:27 EDT
Was this intended to be filed against Fedora? EL6 currently has 2.6.18.
Comment 2 Sam Kottler 2014-02-08 11:03:32 EST
3.4.2 is what's currently available for all supported Fedora releases and EPEL 7 so this is no longer relevant.

Note You need to log in before you can comment on or make changes to this bug.