Bug 100531 - httpd-2.0.45-14 starts, but always dies shortly after
httpd-2.0.45-14 starts, but always dies shortly after
Status: CLOSED DUPLICATE of bug 97207
Product: Red Hat Linux Beta
Classification: Retired
Component: php (Show other bugs)
beta1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
http://mark.mielke.cc/httpd.strace.txt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 02:20 EDT by Mark Mielke
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Mielke 2003-07-23 02:20:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
'/etc/rc.d/init.d/httpd start' or '/usr/sbin/httpd' both appear to complete
successfully (in the former case, it lists 'OK', and in the latter, a command
prompt is returned - in both cases syslog shows 'httpd startup succeeded'),
however, the process only lives for a few ticks, and then dies an abrupt death.

I produced a minimal httpd.conf to reproduce this problem:

    User                    apache
    Group                   apache
 
    ServerRoot              "/etc/httpd"
    PidFile                 "/etc/httpd/run/httpd.pid"
 
    Listen                  8000
 
    LoadModule perl_module modules/mod_perl.so
    LoadModule php4_module modules/libphp4.so
    LoadModule ssl_module modules/mod_ssl.so

If any of the LoadModule lines are commented out, the problem
disappears. All three seem to need to be present in order for me
to reproduce my difficulty. The strace output for a sample failure
can be found at:

     http://mark.mielke.cc/httpd.strace.txt

From the strace output, it looks like /usr/lib/php4/snmp.so is
doing something improper. There is another ticket that describes
similar behaviour to mine in bugzilla that refers to issues with
php4/snmp.so but is not specific enough, and describes different
behavior.

Version-Release number of selected component (if applicable):
httpd-2.0.45-14

How reproducible:
Always

Steps to Reproduce:
Execute /usr/sbin/httpd using the config file from the
Description text.

Actual Results:
httpd dies with sigsegv shortly after it successfully starts.

Expected Results:
httpd should live.
Comment 1 Joe Orton 2003-07-23 06:41:40 EDT
OK, and if you remove the php-snmp package does this go away?
Comment 2 Mark Mielke 2003-07-23 11:18:20 EDT
After removing php-snmp using 'rpm -ev', I am unable to reproduce the problem
with the httpd.conf from the Description text.

So it looks as if I am experiencing the same problem as the other ticket,
although in my case, httpd continued to crash when I booted up with
linux-2.4.21. (The other person experiencing this or a similar problem
claimed that the problem only appeared when using the beta1 kernel)
Comment 3 Thomas M Steenholdt 2003-07-24 00:25:51 EDT
I had this same problem... checking the ssl_error_log showed that the ssl
certificate that is installed by default is for hostname=localhost.localdomain,
and when i installed severn, i chose a different hostname for my machine.
What worked for me was to rename /etc/httpd/conf.d/ssl.conf to ssl.orig (to
avoid having ssl loaded) after that it worked again!
Comment 4 Joe Orton 2003-07-24 05:58:41 EDT

*** This bug has been marked as a duplicate of 97207 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:57:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.