Bug 100539 - (ACPI) Dell Inspiron 8000 fn keys to suspend fail with acpi
Summary: (ACPI) Dell Inspiron 8000 fn keys to suspend fail with acpi
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 07:52 UTC by Alexandre Oliva
Modified: 2013-07-03 02:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-19 20:02:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2003-07-23 07:52:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I realize this is a known limitation of acpi in 2.4 kernels (isn't it?), but I
thought I'd report it for the record.  Unless I boot my laptop with acpi=off,
the keys used to suspend to memory or to disk, to power-off the display, and
show the battery status don't work.

Given these limitations in acpi, perhaps it would be a good idea to add such
laptops to an acpi gray-list (i.e., acpi is not broken, but is not enabled by
default)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot Dell Inspiron 8000 without acpi=off
2.Press Fn ESC (suspend to memory), Fn a (suspend to disk), Fn d (power off the
display)

Actual Results:  Nothing happens

Expected Results:  Ideally, it should work just like it does with acpi=off

Additional info:

Comment 1 Michael K. Johnson 2003-08-18 20:28:31 UTC
It's not possible to have both ACPI and APM.  This is something that just
is not a bug, and is a natural consequence of things like sleeping just
not working in 2.4 ACPI.

Because of the limitations of 2.4 ACPI, it looks like defaulting to
acpi being off, and being able to turn it on where necessary, will work
better...

Comment 2 Alexandre Oliva 2003-08-18 20:57:24 UTC
Agreed.  It is not a bug, but it is a problem.  Not being able to blank the
screen when it's not in use means shorter life for the LCD display.  If only it
would blank properly after some period of time.  But it doesn't, it goes black
but it keeps glowing.  But that's a different bug.

Comment 3 Alexandre Oliva 2003-10-19 20:02:31 UTC
Since ACPI is disabled by default, this is no longer an issue.


Note You need to log in before you can comment on or make changes to this bug.