Bug 1005420 - man page needs entry for new status option --ondate
man page needs entry for new status option --ondate
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deon Ballard
John Sefler
: Documentation
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-06 16:57 EDT by John Sefler
Modified: 2013-11-21 16:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:28:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-09-06 16:57:10 EDT
Description of problem:
The "--ondate" option has been newly added to the subsciption-manager status module.  The man page needs an update to include a short description of --ondate.

[root@jsefler-6 ~]# subscription-manager status --help
Usage: subscription-manager status [OPTIONS]

Show status information for this system's subscriptions and products

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy URL in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for HTTP proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for HTTP proxy with basic authentication
  --ondate=ON_DATE      future date to check status on, defaults to today's
                        date (example: 2013-09-06)
  ^^^^^^^^^^^^^^^^
  newly added option


Also note that when status is called, the actual format of the status output is different than what is seen in the man page.  Here is a real example...


[root@system ~]# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Invalid

Red Hat Enterprise Linux Server:
- Not covered by a valid subscription.




Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.9.5-1.el6.x86_64
[root@jsefler-6 ~]# man -P cat subscription-manager | tail -1
version 2.7                      May 23, 2013          subscription-manager(8)
Comment 1 Deon Ballard 2013-10-13 15:02:41 EDT
Checked in: d610508ae1634e86559fd6ec6d7578ae9cd50035
Comment 4 Sharath Dwaral 2013-10-17 09:36:38 EDT
Version:
# subscription-manager version 
server type: This system is currently not registered.
subscription management server: 0.8.29-1
subscription-manager: 1.9.11-1.el6
python-rhsm: 1.9.6-1.el6


Man page entry for STATUS option has --ondate


STATUS OPTIONS
       The  status command shows the current status of the products and attached subscriptions for the system. If some products are not fully covered or subscriptions have expired, then the
       status command shows why subscriptions are not current.

       [root@server ~]# subscription-manager status
       +-------------------------------------------+
            System Status Details
       +-------------------------------------------+
       Overall Status: Valid

       --ondate=DATE
              Shows the system status for a specific date in the future. The format of the date is YYYY-MM-DD.

              [root@server ~]# subscription-manager status --ondate=2014-01-01
              +-------------------------------------------+
                   System Status Details
              +-------------------------------------------+
              Overall Status: Insufficient


man -P cat subscription-manager | tail -1
version 2.7                      May 23, 2013          subscription-manager(8)


VERIFIED
Comment 5 errata-xmlrpc 2013-11-21 16:28:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.