Bug 1005430 - rct cat-manifest fails to display all the provided products from the embedded entitlement cert
rct cat-manifest fails to display all the provided products from the embedded...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-09-06 18:25 EDT by John Sefler
Modified: 2014-01-21 15:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 15:07:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2013-09-06 18:25:17 EDT
Description of problem:
Attached is a manifest exported from the stage customer portal.
running rct cat-manifest on it does not report all of the provided products that are actually contained in the manifest's entitlement.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@jsefler-5 tmp]# rct dump-manifest manifest_SER0406.zip --force
The manifest has been dumped to the current directory
[root@jsefler-5 tmp]# rct cat-cert export/entitlement_certificates/6130717348613909078.pem --no-content

+-------------------------------------------+
	Entitlement Certificate
+-------------------------------------------+

Certificate:
	Path: export/entitlement_certificates/6130717348613909078.pem
	Version: 1.0
	Serial: 6130717348613909078
	Start Date: 2012-08-13 04:00:00+00:00
	End Date: 2013-08-13 03:59:59+00:00
	Pool ID: Not Available

Subject:
	CN: 8a99f9843e47b88d013e5c134a265217

Issuer:
	C: US
	CN: Red Hat Candlepin Authority
	O: Red Hat, Inc.
	OU: Red Hat Network
	ST: North Carolina
	emailAddress: ca-support@redhat.com

Product:
	ID: 191
	Name: Red Hat OpenStack
	Version: 
	Arch: x86_64
	Tags: 

Product:
	ID: 69
	Name: Red Hat Enterprise Linux Server
	Version: 
	Arch: x86_64,ia64,x86
	Tags: 

Order:
	Name: Red Hat Essex Tech Preview
	Number: 
	SKU: SER0406
	Contract: 3169530
	Account: 540155
	Service Level: None
	Service Type: None
	Quantity: 1
	Quantity Used: 1
	Socket Limit: 4
	RAM Limit: 
	Core Limit: 
	Virt Only: False
	Subscription: 
	Stacking ID: 
	Warning Period: 0
	Provides Management: 0


^^^ NOTICE THAT THERE ARE TWO PRODUCTS (191 and 69) PROVIDED IN THIS ENTILEMENT


[root@jsefler-5 tmp]# rct cat-manifest manifest_SER0406.zip 

+-------------------------------------------+
	Manifest
+-------------------------------------------+

General:
	Server: access.stage.redhat.com/management/distributors/
	Server Version: 0.8.16-1
	Date Created: 2013-08-12T17:26:02.214+0000
	Creator: rhn-cservice-acarter

Consumer:
	Name: MyOrg
	UUID: 98006fa8-516d-4a73-8d1b-4f3229ee831c
	Type: sam

Subscription:
	Name: Red Hat Essex Tech Preview
	Quantity: 1
	Created: 2013-04-30T17:52:48.000+0000
	Start Date: 2012-08-13T04:00:00.000+0000
	End Date: 2013-08-13T03:59:59.000+0000
	Service Level: None
	Service Type: None
	Architectures: x86_64
	SKU: SER0406
	Contract: 3169530
	Order: 
	Account: 540155
	Entitlement File: export/entitlements/8a99f9843e47b88d013e5c134a265217.json
	Certificate File: export/entitlement_certificates/6130717348613909078.pem
	Certificate Version: 1.0
	Provided Products:
		191: Red Hat OpenStack
	Content Sets:
		/content/beta/rhel/server/5/$releasever/$basearch/cf-tools/1/os
		/content/beta/rhel/server/5/$releasever/$basearch/cf-tools/1/source/SRPMS
		/content/beta/rhel/server/5/$releasever/$basearch/debug
		/content/beta/rhel/server/5/$releasever/$basearch/iso
		/content/beta/rhel/server/5/$releasever/$basearch/os
		/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/debug
		/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/os
		/content/beta/rhel/server/5/$releasever/$basearch/rhev-agent/3/source/SRPMS
		/content/beta/rhel/server/5/$releasever/$basearch/source/SRPMS
		/content/beta/rhel/server/5/$releasever/$basearch/source/iso
		/content/beta/rhel/server/5/$releasever/$basearch/supplementary/debug
		/content/beta/rhel/server/5/$releasever/$basearch/supplementary/iso
		/content/beta/rhel/server/5/$releasever/$basearch/supplementary/os
		/content/beta/rhel/server/5/$releasever/$basearch/supplementary/source/SRPMS
		/content/beta/rhel/server/5/$releasever/$basearch/vt/debug
		/content/beta/rhel/server/5/$releasever/$basearch/vt/os
		/content/beta/rhel/server/5/$releasever/$basearch/vt/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/cf-tools/1/debug
		/content/beta/rhel/server/6/$releasever/$basearch/cf-tools/1/os
		/content/beta/rhel/server/6/$releasever/$basearch/cf-tools/1/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/debug
		/content/beta/rhel/server/6/$releasever/$basearch/iso
		/content/beta/rhel/server/6/$releasever/$basearch/openstack/essex/debug
		/content/beta/rhel/server/6/$releasever/$basearch/openstack/essex/os
		/content/beta/rhel/server/6/$releasever/$basearch/openstack/essex/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/optional/debug
		/content/beta/rhel/server/6/$releasever/$basearch/optional/os
		/content/beta/rhel/server/6/$releasever/$basearch/optional/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/os
		/content/beta/rhel/server/6/$releasever/$basearch/rhev-agent/3/debug
		/content/beta/rhel/server/6/$releasever/$basearch/rhev-agent/3/os
		/content/beta/rhel/server/6/$releasever/$basearch/rhev-agent/3/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/source/iso
		/content/beta/rhel/server/6/$releasever/$basearch/subscription-asset-manager/debug
		/content/beta/rhel/server/6/$releasever/$basearch/subscription-asset-manager/os
		/content/beta/rhel/server/6/$releasever/$basearch/subscription-asset-manager/source/SRPMS
		/content/beta/rhel/server/6/$releasever/$basearch/supplementary/debug
		/content/beta/rhel/server/6/$releasever/$basearch/supplementary/iso
		/content/beta/rhel/server/6/$releasever/$basearch/supplementary/os
		/content/beta/rhel/server/6/$releasever/$basearch/supplementary/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/cf-tools/1/os
		/content/dist/rhel/server/5/$releasever/$basearch/cf-tools/1/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/debug
		/content/dist/rhel/server/5/$releasever/$basearch/iso
		/content/dist/rhel/server/5/$releasever/$basearch/os
		/content/dist/rhel/server/5/$releasever/$basearch/productivity/debug
		/content/dist/rhel/server/5/$releasever/$basearch/productivity/os
		/content/dist/rhel/server/5/$releasever/$basearch/productivity/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/debug
		/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/os
		/content/dist/rhel/server/5/$releasever/$basearch/rhev-agent/3/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/source/iso
		/content/dist/rhel/server/5/$releasever/$basearch/supplementary/debug
		/content/dist/rhel/server/5/$releasever/$basearch/supplementary/iso
		/content/dist/rhel/server/5/$releasever/$basearch/supplementary/os
		/content/dist/rhel/server/5/$releasever/$basearch/supplementary/source/SRPMS
		/content/dist/rhel/server/5/$releasever/$basearch/vt/debug
		/content/dist/rhel/server/5/$releasever/$basearch/vt/os
		/content/dist/rhel/server/5/$releasever/$basearch/vt/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/cf-tools/1/debug
		/content/dist/rhel/server/6/$releasever/$basearch/cf-tools/1/os
		/content/dist/rhel/server/6/$releasever/$basearch/cf-tools/1/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/debug
		/content/dist/rhel/server/6/$releasever/$basearch/iso
		/content/dist/rhel/server/6/$releasever/$basearch/openstack/folsom/debug
		/content/dist/rhel/server/6/$releasever/$basearch/openstack/folsom/os
		/content/dist/rhel/server/6/$releasever/$basearch/openstack/folsom/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/optional/debug
		/content/dist/rhel/server/6/$releasever/$basearch/optional/os
		/content/dist/rhel/server/6/$releasever/$basearch/optional/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/os
		/content/dist/rhel/server/6/$releasever/$basearch/rhev-agent/3/debug
		/content/dist/rhel/server/6/$releasever/$basearch/rhev-agent/3/os
		/content/dist/rhel/server/6/$releasever/$basearch/rhev-agent/3/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/source/iso
		/content/dist/rhel/server/6/$releasever/$basearch/subscription-asset-manager/1/debug
		/content/dist/rhel/server/6/$releasever/$basearch/subscription-asset-manager/1/os
		/content/dist/rhel/server/6/$releasever/$basearch/subscription-asset-manager/1/source/SRPMS
		/content/dist/rhel/server/6/$releasever/$basearch/supplementary/debug
		/content/dist/rhel/server/6/$releasever/$basearch/supplementary/iso
		/content/dist/rhel/server/6/$releasever/$basearch/supplementary/os
		/content/dist/rhel/server/6/$releasever/$basearch/supplementary/source/SRPMS


^^^ NOTICE THAT ONLY 191: Red Hat OpenStack APPEARS AS A PROVIDED PRODUCT. EXPECTED 69 TOO.


Expected results:
	Provided Products:
		191: Red Hat OpenStack
		69: Red Hat Enterprise Linux Server
Comment 2 Devan Goodwin 2013-09-19 13:54:54 EDT
I think this sounds very similar to https://bugzilla.redhat.com/show_bug.cgi?id=1006385

Sometimes manifests seem to be generated missing product certs. This is likely an issue with the adapters somehow but the real cause is not yet known.
Comment 3 Devan Goodwin 2013-10-16 08:42:13 EDT
Unable to reproduce or even come up with any way this is even theoretically possible. Moving back to new for now.
Comment 4 RHEL Product and Program Management 2013-10-19 08:54:49 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Devan Goodwin 2014-01-21 15:07:42 EST
Closing for time being, please reopen if we spot this again or get a reproducer.

Note You need to log in before you can comment on or make changes to this bug.