Bug 1005436 - timerEvent firing creates extra JoinInstance on a persistent process
timerEvent firing creates extra JoinInstance on a persistent process
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Maciej Swiderski
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 19:01 EDT by Marian Buenosayres
Modified: 2014-08-06 16:11 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Maven project to test the issue (30.90 KB, application/x-gzip)
2013-09-06 19:01 EDT, Marian Buenosayres
no flags Details

  None (edit)
Description Marian Buenosayres 2013-09-06 19:01:37 EDT
Created attachment 795002 [details]
Maven project to test the issue

Attached project with JUnit test to see it:

    A persistent process with two live activities, a workItem and a timerEvent (see attached image
    The workItem fires, and one side of the execution waits in a safe state in the AND join.
    When the timer events, the TimerNodeInstance is notified, but it creates another JoinInstance instead of using the existing one.
    Since it is an AND join, it never continues because one JoinInstance has one incoming connection satisfied, and the other JoinInstance has the other.

If this is due to writing my BPMN2 wrong or a configuration, please let me know. I'm pretty sure the process should be valid as is.
Comment 2 Maciej Swiderski 2013-09-09 13:56:02 EDT
corrected issue with missing level marker for TimerNodeInstance upon it's completion which caused the join node instance to be created.

Committed to both master and 6.0.x
Master
https://github.com/droolsjbpm/jbpm/commit/9f5a54face7e9757744bac730799b2df9cd14135

6.0.x
https://github.com/droolsjbpm/jbpm/commit/bd0f3fe37529aad3b9e214ca4e97eeffc6503fd6
Comment 3 Ivo Bek 2013-10-18 03:31:54 EDT
Verified in BPMS 6.0.0.ER4

Note You need to log in before you can comment on or make changes to this bug.