Bug 1005441 - can't threaddump on an app after it's started from a stopped state.
can't threaddump on an app after it's started from a stopped state.
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 19:56 EDT by Peter Ruan
Modified: 2015-05-14 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 16:58:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-09-06 19:56:27 EDT
Description of problem:
  Broker reports that it can't detect applicationi PID, after the app is stopped and started back up and followed by a 'rhc threaddump' command.


Version-Release number of selected component (if applicable):
current

How reproducible:
always.

Steps to Reproduce:
1. create a ruby app
2. stop the app
3. start the app to bring it back online
4. do 'rhc threaddump <app_name>'


Actual results:
 Unable to detect application PID. Check the application's availability by accessing http://ngzozq-pppp.rhcloud.com


Expected results:
able to execute threaddump.

Additional info:
Comment 1 Qiushui Zhang 2013-09-09 03:20:04 EDT
Hi Peter,

Did you visit the website of the app before you do the threaddump after app started?

You need to visit the app from website in browser or by curl command, before every threaddump. I did not see this step in your bug description.


Best Regards,
Walter
Comment 2 Michal Fojtik 2013-09-09 05:53:17 EDT
IMHO the 'curl' is something which the 'rhc threadump' should do automatically.
Comment 3 Peter Ruan 2013-09-09 15:05:28 EDT
Hi Walter,
  I didn't visit the app's page for ruby, but I didn't have to do that for jboss apps.

Jhon,
  I looked at the problem again and it looks like threaddump does not work after the app is created...stopping the app or not doens't seem to play a part in this problem.  When I looked at the development.log file, broker reports a 200 when the RHC command is run.

Thanks,
-peter

Note You need to log in before you can comment on or make changes to this bug.