Bug 1005459 - Rename Review: wmdocker - KDE and GNOME2 system tray replacement docking application
Rename Review: wmdocker - KDE and GNOME2 system tray replacement docking app...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 04:07 EDT by Andreas Bierfert
Modified: 2013-11-18 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 12:14:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mattdm: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Andreas Bierfert 2013-09-07 04:07:06 EDT
Spec URL: http://fedora.lowlatency.de/review/wmdocker.spec 
SRPM URL: http://fedora.lowlatency.de/review/wmdocker-1.5-11.fc19.src.rpm
Koji: https://koji.fedoraproject.org/koji/taskinfo?taskID=5907199

Description:
Docker is a docking application (WindowMaker dock app) which acts as a system
tray for KDE and GNOME2. It can be used to replace the panel in either
environment, allowing you to have a system tray without running the KDE/GNOME
panel or environment.

Fedora Account System Username: awjb

See https://fedorahosted.org/fpc/ticket/341.
Comment 1 Matthew Miller 2013-09-09 14:21:22 EDT
Note as per https://fedorahosted.org/fpc/ticket/341#comment:7, it is okay to omit  "Provides: docker" (and this spec file does). Obsoletes is also properly provided, with a conditional for < f22. (That can, of course, be dropped in the future, but the conditional seems like a good idea too.)
Comment 2 Matthew Miller 2013-09-09 14:31:08 EDT
A few small things on review:

- the license should actually be "GPLv2+", not "GPL".
- you can drop the %defattr if you like
- same with Buildroot
- and with %clean section


And a bigger question: do we want to rename the binary to wmdocker?
Comment 3 Andreas Bierfert 2013-09-10 16:36:34 EDT
Thanks for taking up the review.

I will change the stuff you pointed out asap.

I thought about the rename myself but came to the conclusion that if we provide a clean upgrade path users will probably have a smooth transition package wise but will be missing their docker dockapp... if they pinpoint it to the rename it is not a problem however. Will the new docker package provide a docker binary?
Comment 4 Matthew Miller 2013-09-10 16:42:24 EDT
Yes, it has a docker binary, and that's much harder to change than the package name, since a lot of external documentation will talk about it (and the upstream is very concerned about a pleasant/seamless/same-everywhere user experience).
Comment 5 Andreas Bierfert 2013-09-10 16:56:26 EDT
Ok, before we add a conflicts I will rename the binary as well.
Comment 7 Matthew Miller 2013-09-21 15:15:08 EDT
whoops sorry for dropping this on the floor for a bit there.  Review passed.
Comment 8 Andreas Bierfert 2013-11-16 04:56:04 EST
New Package SCM Request
=======================
Package Name: wmdocker
Short Description: KDE and GNOME2 system tray replacement docking application
Owners: awjb
Branches: f20
Comment 9 Gwyn Ciesla 2013-11-18 08:02:45 EST
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.