Bug 1005460 - quota: "df -h" does not display an existing mount once deem-statfs is put to on
quota: "df -h" does not display an existing mount once deem-statfs is put to on
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 04:07 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Previously, when deem-statfs option is set on a quota enabled volume with no data, 'df' did not display disk usage statistics for the mount of the volume. Now, with this update this issue has been fixed and 'df' reports correct statistics on a volume with no data.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:36:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-09-07 04:07:32 EDT
Description of problem:
for a volume that is already mounted using nfs.
if a deem-statfs option is set to on
"df -h" does not display, whereas the mount is still there.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.32rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. mount a volume over nfs,
2. enable quota
3. set deem-statfs on
4. df -h on client

Actual results:

df does not display the mount, whereas the mount is still there,
as can be seen from here,

[root@rhsauto036 ~]# df -h

Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_rhsauto036-lv_root
                       50G  2.1G   45G   5% /
tmpfs                 939M     0  939M   0% /dev/shm
/dev/sda1             485M   37M  423M   8% /boot
/dev/mapper/vg_rhsauto036-lv_home
                      213G  188M  202G   1% /home
rhsqe-repo.lab.eng.blr.redhat.com:opt
                      1.9T   94G  1.7T   6% /opt
[root@rhsauto036 ~]# 
[root@rhsauto036 ~]# 
[root@rhsauto036 ~]# 
[root@rhsauto036 ~]# mount | grep newvol
nfs1:newvol on /mnt/nfs-test-newvol type nfs (rw,addr=10.70.37.213)
[root@rhsauto036 ~]# ls /mnt/nfs-test-newvol/
a  d1  saurabh-dir1


Expected results:
df should display information about the existing mountpoint even after setting the deem-statfs option

Additional info:
Comment 3 vpshastry 2013-09-10 03:21:58 EDT
The bug is observed only when the usage is zero. ie, after any write in the mountpoint, df shows the correct output. 


# gluster volume info t
 
Volume Name: t
Type: Distribute
Volume ID: 748ac711-880f-4481-9f52-80a3fd80d657
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: vpshastry:/export1/b1
Brick2: vpshastry:/export2/b1
Options Reconfigured:
features.quota-deem-statfs: on
features.quota: on

# df -h
Filesystem      Size  Used Avail Use% Mounted on
<no output of the mountpoints shown>

# mount
localhost:t on /mnt/tmp/tnfs type nfs (rw,vers=3,addr=127.0.1.1)
localhost:t on /mnt/tmp/tfuse type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)

# gluster volume quota t list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                        200.0MB       80%      0Bytes 200.0MB
# dd if=/dev/urandom of=/mnt/tmp/tfuse/a bs=1M count=5
5+0 records in
5+0 records out
5242880 bytes (5.2 MB) copied, 0.366647 s, 14.3 MB/s

# df -h
Filesystem      Size  Used Avail Use% Mounted on
localhost:t     200M  5.0M  195M   3% /mnt/tmp/tnfs
localhost:t     200M  5.0M  195M   3% /mnt/tmp/tfuse
Comment 4 vpshastry 2013-09-10 05:25:53 EDT
We copy the maximum usage of the sub-childlren of the dht if deem-statfs option is on, because each subvol gives the complete information.

Cause: When the usage is zero, the check for maximum of usages leaves the statvfs structure behind, not progressing upwards in UNWIND.

The patch https://code.engineering.redhat.com/gerrit/12660 fixes the issue.
Comment 7 errata-xmlrpc 2013-11-27 10:36:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.