This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1005467 - kdeartwork included Trademark'ed icons.
kdeartwork included Trademark'ed icons.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeartwork (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-09-07 06:22 EDT by mejiko
Modified: 2015-08-05 09:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-05 09:52:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description mejiko 2013-09-07 06:22:36 EDT
Hello.

kdeartworks included trademark'ed icons.

Files:

kdeartwork-4.10.5/IconThemes/nuvola/*/apps/acroread.png
kdeartwork-4.10.5/IconThemes/nuvola/*/apps/mozilla*.png
kdeartwork-4.10.5/IconThemes/nuvola/*/apps/realplayer.png
kdeartwork-4.10.5/IconThemes/mono/scalable/apps/acroread.svgz
kdeartwork-4.10.5/IconThemes/mono/scalable/apps/mozilla*.svgz
kdeartwork-4.10.5/IconThemes/mono/scalable/apps/opera.svgz
kdeartwork-4.10.5/IconThemes/mono/scalable/apps/mac.svgz

This is trademark problem, Its non-free.

Suggests:

1. remove trademark'ed icons

2. replace fedora free (fedora acceptable licensed) icons.

3. remove fedora repos.


Thanks.
Comment 1 mejiko 2013-09-07 06:23:16 EDT
Blocking FE-Legal, This is trademark problem.
Comment 2 mejiko 2013-09-07 06:25:31 EDT
I found typo. (in Description) 

incorrent: kdeartworks

corrent: kdeartwork

Sorry.
Comment 3 Kevin Kofler 2013-09-13 17:29:27 EDT
I believe that this is fair/proper use of those trademarks (we are not using them to designate anything other than the trademarked items) and that there are no copyright issues because those are original renditions not derived from the official icons.

So can I close this as NOTABUG?
Comment 4 Tom "spot" Callaway 2013-09-15 20:32:09 EDT
No, because these trademarked icons are not attached to their corresponding software. In the case of most of them, the software they map to isn't even part of Fedora, so including those trademarks is pretty much textbook "confusion".

The possible exception might be the Mozilla icons, except that the Mozilla trademark guidelines specifically ask people not to make modified versions of their icons and distribute them (exactly what this theme is doing):

http://www.mozilla.org/en-US/foundation/trademarks/faq/

Can I modify your logos and distribute the result?
    Please don't. The logos are trademarked, and so if the result is confusingly similar to the original, or used in a confusing manner, it's a violation of trademark law.

******

It might be possible to get permission from Mozilla (or for that matter, any of the other trademark owners) to include this themed version of their icons in Fedora, but without that, they have to go.
Comment 5 Kevin Kofler 2013-09-15 20:53:42 EDT
Uh, it'd be confusion if we were putting Icon=acroread on Okular or something, but as it stands, those icons will not be shown to the user at all except in conjunction with the software they are for. So I'm confused ;-) as to where the confusion would be.

That said, the issue of looking "almost but not quite" like the trademarks makes sense to me. (I don't think they're really "modified" in the copyright sense, i.e. as in "pick the original icon and edit that", but of course they do look similar to the originals, that's the point.)

So I conclude that these will have to go. :-( It's a disservice to our users (as they will get generic rather than themed icons), but if that's what the trademark owners want, we can't do much about that (and from what I gathered at KDE upstream, I believe the general trend is towards just using unthemed hicolor application icons anyway, because application developers think their visual identity is more important than consistent theming, even where the logo is not a registered trademark).
Comment 6 mejiko 2014-03-15 06:09:45 EDT
Changed to rawhide.

How it this bug current status ? 
Is this bug is resolved ?

Thanks.
Comment 7 Jaroslav Reznik 2015-03-03 10:02:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 8 mejiko 2015-08-05 05:09:22 EDT
How it this bug current status ? 
Is this bug is resolved ?

Thanks.
Comment 9 Rex Dieter 2015-08-05 09:52:59 EDT
Thanks for reminder,

%changelog
* Wed Aug 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 15.04.3-1
- 15.04.3
- omit trademarked icons (#1005467)

Note You need to log in before you can comment on or make changes to this bug.