Bug 100547 - minicom is not UTF-8 aware
Summary: minicom is not UTF-8 aware
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: minicom   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 81694 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 11:06 UTC by Milan Kerslager
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-18 13:38:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the UTF-8 non aware problem under Fedora Core 4 (62.34 KB, image/png)
2006-02-28 14:16 UTC, Nicolas Scheibling
no flags Details

Description Milan Kerslager 2003-07-23 11:06:05 UTC
Minicom is unable to display UTF-8 characters in its own menu dialogs. My locale
is cs_CZ.UTF-8, try to enter configuration dialog (press CTRL+a).

Comment 1 Milan Kerslager 2003-07-23 11:07:05 UTC
*** Bug 81694 has been marked as a duplicate of this bug. ***

Comment 2 Martin Stransky 2005-07-18 13:38:34 UTC
Adding support for UTF8 to minicom is difficult for us, because it uses its own
function for printing and managing window (scrolling, line breaking and so on...). 
Adding support for UTF8 means rewriting big parts of window.c and it causes
incompatibility with upstream package (e.g. UTF8 uses different size of
characters, minicom uses only one byte chars...).

This issue has been reported to upstream.

Comment 3 Nicolas Scheibling 2006-02-28 14:16:20 UTC
Created attachment 125397 [details]
Screenshot of the UTF-8 non aware problem under Fedora Core 4

This bug have been reported to upstream since 05/04/2004 13:53

[ #300619 ] minicom can't cope with unicode
http://alioth.debian.org/tracker/index.php?func=detail&aid=300619&group_id=30018&atid=100031


Note You need to log in before you can comment on or make changes to this bug.