Bug 1005492 - printing to cups-pdf printer generates a corrupt pdf file
printing to cups-pdf printer generates a corrupt pdf file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 11:12 EDT by Joachim Backes
Modified: 2013-09-16 01:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 01:44:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a corrupt pdf file generated by cups-pdf (2.17 KB, application/octet-stream)
2013-09-07 11:16 EDT, Joachim Backes
no flags Details
/etc/cups/cups-pdf.conf (9.43 KB, text/plain)
2013-09-07 11:20 EDT, Joachim Backes
no flags Details
input from gnome-terminal (ls -l) (642 bytes, text/plain)
2013-09-13 02:58 EDT, Joachim Backes
no flags Details
generated pdf by "lpr -Ppdf input" (2.17 KB, application/force-download)
2013-09-13 03:00 EDT, Joachim Backes
no flags Details
firefox print (74.98 KB, application/pdf)
2013-09-13 08:56 EDT, Dethlef Madsen
no flags Details

  None (edit)
Description Joachim Backes 2013-09-07 11:12:54 EDT
Description of problem:
I have installed cups-pdf. If I try to print some text on cups-pdf printer, the generated PDF file is corrupt and can't be shown be evince.

Version-Release number of selected component (if applicable):
cups-pdf-2.6.1-5.fc20.x86_64

How reproducible:
alwyays

Steps to Reproduce:
1.lpr <some-tex> -P<cups-pdf-printer>
2.
3.

Actual results:
The generated PDF file can't be shown by evince or acroread

Expected results:


Additional info:
Comment 1 Joachim Backes 2013-09-07 11:16:59 EDT
Created attachment 795123 [details]
a corrupt pdf file generated by cups-pdf
Comment 2 Joachim Backes 2013-09-07 11:20:52 EDT
Created attachment 795124 [details]
/etc/cups/cups-pdf.conf
Comment 3 Joachim Backes 2013-09-13 01:27:26 EDT
Still the same effect with cups-pdf-2.6.1-6.fc20.x86_64
Comment 4 Remi Collet 2013-09-13 01:34:26 EDT
Sorry, but I cannot reproduce.
Please provide a sample "input" text.
Comment 5 Joachim Backes 2013-09-13 02:58:11 EDT
Created attachment 797159 [details]
input from gnome-terminal (ls -l)
Comment 6 Joachim Backes 2013-09-13 03:00:41 EDT
Created attachment 797161 [details]
generated pdf by "lpr -Ppdf input"
Comment 7 Remi Collet 2013-09-13 07:22:09 EDT
Cannot reproduce with default Cups-PDF printer created during RPM install.

How your "pdf" printer was created ?

Can you try with this command :

/usr/sbin/lpadmin -p Cups-PDF -v cups-pdf:/ -m CUPS-PDF.ppd -E
Comment 8 Dethlef Madsen 2013-09-13 08:56:28 EDT
Created attachment 797318 [details]
firefox print

Works correct for me. Installed via yum from testing.

cups-pdf-2.6.1-6.fc20.x86_64
Comment 9 Joachim Backes 2013-09-13 12:47:08 EDT
(In reply to Remi Collet from comment #7)
> Cannot reproduce with default Cups-PDF printer created during RPM install.
> 
> How your "pdf" printer was created ?

system-config-printer

> 
> Can you try with this command :
> /us
> r/sbin/lpadmin -p Cups-PDF -v cups-pdf:/ -m CUPS-PDF.ppd -E

No change :-(

But:
----

I could solve my problem by removing the cups-pdf printer and recreating it again by system-config-printer. So I think I made previously some errors. You may close the ticket as "no error".
Comment 10 Remi Collet 2013-09-16 01:44:26 EDT
Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.