Bug 1005520 - [abrt] qmmp-0.7.1-2.fc19: __gnu_cxx::__verbose_terminate_handler: Process /usr/bin/qmmp was killed by signal 6 (SIGABRT)
[abrt] qmmp-0.7.1-2.fc19: __gnu_cxx::__verbose_terminate_handler: Process /us...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qmmp (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Volný
Fedora Extras Quality Assurance
abrt_hash:e60c06e631fe333d048fa430340...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 20:16 EDT by Gerald Cox
Modified: 2014-01-17 07:28 EST (History)
2 users (show)

See Also:
Fixed In Version: qmmp-0.7.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-17 07:28:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (55.75 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: core_backtrace (27.37 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: dso_list (23.08 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: environ (1.89 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: maps (116.03 KB, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: open_fds (787 bytes, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: proc_pid_status (947 bytes, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details
File: var_log_messages (436 bytes, text/plain)
2013-09-07 20:16 EDT, Gerald Cox
no flags Details

  None (edit)
Description Gerald Cox 2013-09-07 20:16:24 EDT
Description of problem:
I had a playlist running... and it dumped while playing...

Version-Release number of selected component:
qmmp-0.7.1-2.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /bin/qmmp -session 10d2d66172000137839838100000021410024_1378398487_721332
crash_function: __gnu_cxx::__verbose_terminate_handler
executable:     /usr/bin/qmmp
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 __gnu_cxx::__verbose_terminate_handler at ../../../../libstdc++-v3/libsupc++/vterminate.cc:95
 #3 __cxxabiv1::__terminate at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:38
 #4 std::terminate at ../../../../libstdc++-v3/libsupc++/eh_terminate.cc:48
 #5 __cxxabiv1::__cxa_pure_virtual at ../../../../libstdc++-v3/libsupc++/pure.cc:50
 #6 StateHandler::dispatch at /usr/src/debug/qmmp-0.7.1/src/qmmp/statehandler.cpp:65
 #7 OutputWriter::dispatch at /usr/src/debug/qmmp-0.7.1/src/qmmp/outputwriter.cpp:250
 #8 OutputWriter::status at /usr/src/debug/qmmp-0.7.1/src/qmmp/outputwriter.cpp:398
 #9 OutputWriter::run at /usr/src/debug/qmmp-0.7.1/src/qmmp/outputwriter.cpp:306
 #10 QThreadPrivate::start at thread/qthread_unix.cpp:338
 #12 clone at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
Comment 1 Gerald Cox 2013-09-07 20:16:27 EDT
Created attachment 795258 [details]
File: backtrace
Comment 2 Gerald Cox 2013-09-07 20:16:30 EDT
Created attachment 795259 [details]
File: cgroup
Comment 3 Gerald Cox 2013-09-07 20:16:32 EDT
Created attachment 795260 [details]
File: core_backtrace
Comment 4 Gerald Cox 2013-09-07 20:16:34 EDT
Created attachment 795261 [details]
File: dso_list
Comment 5 Gerald Cox 2013-09-07 20:16:36 EDT
Created attachment 795262 [details]
File: environ
Comment 6 Gerald Cox 2013-09-07 20:16:39 EDT
Created attachment 795263 [details]
File: limits
Comment 7 Gerald Cox 2013-09-07 20:16:41 EDT
Created attachment 795264 [details]
File: maps
Comment 8 Gerald Cox 2013-09-07 20:16:43 EDT
Created attachment 795265 [details]
File: open_fds
Comment 9 Gerald Cox 2013-09-07 20:16:46 EDT
Created attachment 795266 [details]
File: proc_pid_status
Comment 10 Gerald Cox 2013-09-07 20:16:48 EDT
Created attachment 795267 [details]
File: var_log_messages
Comment 11 viking 2013-10-14 09:27:02 EDT
переход на следующий трэк в плей-листе

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /bin/qmmp
crash_function: __gnu_cxx::__verbose_terminate_handler
executable:     /usr/bin/qmmp
kernel:         3.11.3-201.fc19.x86_64
package:        qmmp-0.7.1-2.fc19
reason:         Process /usr/bin/qmmp was killed by signal 6 (SIGABRT)
runlevel:       5 3
type:           CCpp
uid:            1000
Comment 12 Karel Volný 2013-12-11 08:16:18 EST
Hi, sorry for late reaction.

There were some fixes to playlist code (although it seems unrelated to me from the backtrace) in version 0.7.2 which is about to be released as part of Fedora 20.

I did a scratchbuild for F19, please could you test if the updated version fixes the problem for you?

see http://koji.fedoraproject.org/koji/taskinfo?taskID=6279294


(In reply to viking from comment #11)
> переход на следующий трэк в плей-листе

можно говорить на английском языке?

Я понимаю, но другие нет :-) и это трудно для меня писать на азбуке :-(
Comment 13 Gerald Cox 2013-12-28 15:23:09 EST
I've since upgraded to F20 and running 0.7.2 - haven't experienced an issue so far...
Comment 14 Karel Volný 2014-01-17 07:28:16 EST
(In reply to Gerald Cox from comment #13)
> I've since upgraded to F20 and running 0.7.2 - haven't experienced an issue
> so far...

thanks for the feedback, so closing

Note You need to log in before you can comment on or make changes to this bug.