Bug 1005544 - engine.log doesn't include log on custom properties.
engine.log doesn't include log on custom properties.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
low Severity low
: ---
: 3.3.0
Assigned To: Mike Kolesnik
yeylon@redhat.com
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 04:23 EDT by awinter
Modified: 2016-04-18 02:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (222.28 KB, text/x-log)
2013-09-18 06:46 EDT, awinter
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18967 None None None Never

  None (edit)
Description awinter 2013-09-08 04:23:43 EDT
Description of problem:
engine.log doesn't include log on custom properties.

we don't maintain custom_properties on the vnic device level (but on the vnic profile itself), and thus the custom properties will always be empty in the log.

Adding a print to the log will help us know the system's state.


Actual results:

[org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugNicVDSCommand](ajp-/127.0.0.1:8702-13) START,HotPlugNicVDSCommand(HostName=zeus-vds1.qa.lab.tlv.redhat.com, HostId=490811e2-c589-4e5c-a037-1917b6513d2a, vm.vm_name=VM1, nic=nic2{id=3ab24250-e53d-4b9d-a201-fe3aae594713, networkName=testingNetwork,vnicProfileName=null, vnicProfileId=a3e40e6a-6499-4940-b2aa-e2636266c937,speed=1000, type=3,macAddress=00:1a:4a:16:88:61, active=true,linked=true, portMirroring=false,vmId=4e8752f1-7fb0-4972-9adb-299904b6575d, vmName=VM1, vmTemplateId=null},vmDevice=VmDevice
{vmId=4e8752f1-7fb0-4972-9adb-299904b6575d,deviceId=3ab24250-e53d-4b9d-a201-fe3aae594713, device=bridge,type=INTERFACE,bootOrder=0, specParams={}, address={bus=0x00,domain=0x0000, type=pci, slot=0x09, function=0x0}, managed=true,plugged=false, readOnly=false,deviceAlias=net1, customProperties={} }), logid: dc6bbf6

Expected results:

[org.ovirt.engine.core.vdsbroker.vdsbroker.HotPlugNicVDSCommand](ajp-/127.0.0.1:8702-13) START,HotPlugNicVDSCommand(HostName=zeus-vds1.qa.lab.tlv.redhat.com, HostId=490811e2-c589-4e5c-a037-1917b6513d2a, vm.vm_name=VM1, nic=nic2{id=3ab24250-e53d-4b9d-a201-fe3aae594713, networkName=testingNetwork,vnicProfileName=null, vnicProfileId=a3e40e6a-6499-4940-b2aa-e2636266c937,speed=1000, type=3,macAddress=00:1a:4a:16:88:61, active=true,linked=true, portMirroring=false,vmId=4e8752f1-7fb0-4972-9adb-299904b6575d, vmName=VM1, vmTemplateId=null},vmDevice=VmDevice
{vmId=4e8752f1-7fb0-4972-9adb-299904b6575d,deviceId=3ab24250-e53d-4b9d-a201-fe3aae594713, device=bridge,type=INTERFACE,bootOrder=0, specParams={}, address={bus=0x00,domain=0x0000, type=pci, slot=0x09, function=0x0}, managed=true,plugged=false, readOnly=false,deviceAlias=net1, customProperties={'bandwidth': '4501'} }), logid: dc6bbf6
Comment 1 Mike Kolesnik 2013-09-08 08:36:52 EDT
The information can't be printed in the call to XX since it's not available at this point, instead added a logging of profile data more generally to where it's available when starting a VM or hot plugging a NIC.

The log will look like this:
2013-09-08 15:32:54,086 DEBUG [org.ovirt.engine.core.vdsbroker.vdsbroker.VmInfoBuilderBase] (pool-6-thread-50) [2f70459c] VNIC nic2 is using profile ovirtmgmt {id=ecff23f3-25b2-46e4-927b-3a034c7e53e3, networkId=5c8fd919-5bf7-4f4a-8395-8c2504da3655, networkQosId=null, portMirroring=false, customProperties={test=this is a test, aaa=bbb}, description=null} on network ovirtmgmt
Comment 2 awinter 2013-09-18 06:46:59 EDT
Created attachment 799314 [details]
engine.log

Not fixed.

Steps I did:
-----------
1. Created a new custom property "amiProp" via engine (with restart)
2. Created a new network in DC with amiProp = 4567
3. Added the network to eth1 on the host.
4. Created a new VM with the network as nic1.
5. Added a new nic to the VM (Hot Plug Nic) with the same network.

-----------------------------------------------------------

engine.log does not present "amiProp" or "4567" at any step.

See attached engine.log file
Comment 3 awinter 2013-09-18 06:56:25 EDT
Not fixed.

Steps I did:
-----------
1. Created a new custom property "amiProp" via engine (with restart)
2. Created a new network in DC with amiProp = 4567
3. Added the network to eth1 on the host.
4. Created a new VM with the network as nic1.
5. Added a new nic to the VM (Hot Plug Nic) with the same network - VM was DOWN.

-----------------------------------------------------------

engine.log does not present "amiProp" or "4567" at any step.

See attached engine.log file
Comment 4 Moti Asayag 2013-09-18 07:33:46 EDT
(In reply to awinter from comment #3)
> Not fixed.
> 
> Steps I did:
> -----------
> 1. Created a new custom property "amiProp" via engine (with restart)
> 2. Created a new network in DC with amiProp = 4567
> 3. Added the network to eth1 on the host.
> 4. Created a new VM with the network as nic1.
> 5. Added a new nic to the VM (Hot Plug Nic) with the same network - VM was
> DOWN.
> 
> -----------------------------------------------------------
> 
> engine.log does not present "amiProp" or "4567" at any step.
> 
> See attached engine.log file

Correct, the patch was acked but haven't got merged. Moving it back to MODIFIED.

Note that the expected output will appear only in DEBUG level like this one:
2013-09-18 14:29:49,203 DEBUG  [org.ovirt.engine.core.vdsbroker.vdsbroker.VmInfoBuilderBase] (pool-6-thread-48) [e99f2e8] VNIC nic2 is using profile poor {id=28d35593-3e23-4f82-a320-11defad86547, networkId=ee41f3bd-857b-4d1e-bf3b-29b120bd80ab, networkQosId=357fa4de-71ce-4c93-b641-63700949010c, portMirroring=false, customProperties={speed=200, duplex=full}, description=null} on network qos_test
Comment 5 awinter 2013-10-14 09:29:47 EDT
Bug fixed.

My steps:
1. Created a new custom property "amiProp" via engine (with restart)
2. Created a new network in DC with amiProp = 4567
3. Added the network to eth1 on the host.
4. Created a new VM with the networks:
     nic1 = rhevm
     nic2 = amiProp
     nic3 = amiProp
5. Installing the VM with RHEL 6.5
6. Executing hot unplug nic for nic3
7. Executing hot plug nic for nic3
8. Removing nic3

--------
Results:
4. On the creation of the nics, I can see in the log:
    - VNIC nic3 is using profile amiProp {id=31466fcb-1e18-4057-
      ae19-bf2cebd9a74c, networkId=73ebcce1-e1b6-44b5-b920-06d76a357b79, 
      networkQosId=null, portMirroring=false, customProperties={amiProp=4567}, 
      description=null} on  network amiProp
    - VNIC nic2 is using profile amiProp {id=31466fcb-1e18-4057-
      ae19-bf2cebd9a74c, networkId=73ebcce1-e1b6-44b5-b920-06d76a357b79, 
      networkQosId=null, portMirroring=false, customProperties={amiProp=4567}, 
      description=null} on network amiProp
6. On Hot unPlug Nic I get:
    - VNIC nic3 is using profile amiProp {id=31466fcb-1e18-4057-
      ae19-bf2cebd9a74c,networkId=73ebcce1-e1b6-44b5-b920-06d76a357b79, 
      networkQosId=null, portMirroring=false, customProperties={amiProp=4567}, 
      description=null} on network amiProp
7. On Hot Plug Nic I get:
    - VNIC nic3 is using profile amiProp {id=31466fcb-1e18-4057-
      ae19-bf2cebd9a74c, networkId=73ebcce1-e1b6-44b5-b920-06d76a357b79, 
      networkQosId=null, portMirroring=false, customProperties={amiProp=4567}, 
      description=null} on network amiProp
Comment 8 Itamar Heim 2014-01-21 17:24:17 EST
Closing - RHEV 3.3 Released
Comment 9 Itamar Heim 2014-01-21 17:25:11 EST
Closing - RHEV 3.3 Released
Comment 10 Itamar Heim 2014-01-21 17:28:44 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.