Bug 1005551 - Please enable CONFIG_VIRTIO_CONSOLE in arm kernel
Please enable CONFIG_VIRTIO_CONSOLE in arm kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kyle McMartin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-09-08 06:11 EDT by Richard W.M. Jones
Modified: 2015-08-31 23:54 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-3.11.2-301.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:35:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-09-08 06:11:10 EDT
Description of problem:

On armv7hl (Fedora 20):

$ grep VIRTIO.CONSOLE /boot/config-3.11.0-3.fc20.armv7hl 
# CONFIG_VIRTIO_CONSOLE is not set

whereas on x86_64 (Fedora 19):

$ grep VIRTIO.CONSOLE /boot/config-3.10.9-200.fc19.x86_64 
CONFIG_VIRTIO_CONSOLE=y

I checked and virtio-serial works fine on arm (using virtio-mmio),
so we should enable it on arm too.

Version-Release number of selected component (if applicable):

kernel 3.11.0-3.fc20.armv7hl

How reproducible:

100%
Comment 1 Josh Boyer 2013-09-08 07:52:06 EDT
It's enabled as a module in the lpae config fwiw.
Comment 2 Richard W.M. Jones 2013-09-08 08:59:44 EDT
OK, although this is for a guest kernel, so there's
not really a need for us to use the LPAE kernel -- it'd be
nice if it just worked with any kernel that the guest
uses.
Comment 3 Richard W.M. Jones 2013-09-13 10:54:23 EDT
I actually tried to see if I could use the LPAE kernel
but it's a non-starter.  That kernel only supports Samsung
Exygnos devices.  qemu only emulates Versatile Express A15.
Loading the vexpress-v2p-ca15-tc1.dtb with the LPAE kernel
fails with:

0xc08677b7 <__log_buf+591>:	"\202\nError: unrecognized/unsupported device tree compatible list:\n[ 'arm,vexpress,v2p-ca15,tc1' 'arm,vexpress,v2p-ca15' 'arm,vexpress' ]\n"
0xc086784f <__log_buf+743>:	"\202Available machine support:\n\nID (hex)\tNAME"
0xc086788f <__log_buf+807>:	"\202ffffffff\tSAMSUNG EXYNOS5 (Flattened Device Tree)"
0xc08678cf <__log_buf+871>:	"\202\nPlease check your kernel config and/or bootloader."

So we really do need virtio-console to be supported in the regular kernel.
Comment 4 Richard W.M. Jones 2013-09-14 01:53:55 EDT
I built a scratch kernel with virtio-console support and
confirmed it lets libguestfs work:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5932146
Comment 5 Josh Boyer 2013-09-27 11:56:09 EDT
I went ahead and changed this.
Comment 6 Fedora Update System 2013-09-30 12:27:23 EDT
kernel-3.11.2-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.2-301.fc20
Comment 7 Fedora Update System 2013-09-30 22:00:08 EDT
Package kernel-3.11.2-301.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.2-301.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17982/kernel-3.11.2-301.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-02 02:35:16 EDT
kernel-3.11.2-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Peter Robinson 2013-10-02 08:40:36 EDT
This caused issues in the qemu/vexpress image and, from memory, the highbank HW in the past and hence the reason it was disabled. It might well be fixed but it would be useful to actually CC ARM people in to check why it might have been explicitly disabled. Has it been confirmed those issues are now fixed?
Comment 10 Josh Boyer 2013-10-02 08:45:22 EDT
(In reply to Peter Robinson from comment #9)
> This caused issues in the qemu/vexpress image and, from memory, the highbank
> HW in the past and hence the reason it was disabled. It might well be fixed
> but it would be useful to actually CC ARM people in to check why it might
> have been explicitly disabled. Has it been confirmed those issues are now
> fixed?

I did CC ARM people.  The bug was assigned to the ARM kernel maintainer.
Comment 11 Peter Robinson 2013-10-02 09:00:34 EDT
> I did CC ARM people.  The bug was assigned to the ARM kernel maintainer.

But not added to the ARMTracker bug or anyone else that have history as to why it might have been originally disabled
Comment 12 Peter Robinson 2013-10-02 09:03:45 EDT
Ultimately it doesn't matter if there's confirmation that the original issue is now fixed
Comment 13 Richard W.M. Jones 2013-10-02 09:10:24 EDT
I can't find anything related to virtio-console, highbank and
vexpress, either on the mailing list nor on Google (except for
this bug).

Also note virtio-serial is not some nice-to-have, it's a vital
device for virtualization, enabling libguestfs and qemu-ga.
Comment 14 Peter Robinson 2013-10-02 09:18:06 EDT
> Also note virtio-serial is not some nice-to-have, it's a vital
> device for virtualization, enabling libguestfs and qemu-ga.

I don't disagree, I'm just mentioning the reason it was disabled was because it broke things in the past so we need to confirm this is no longer the case.
Comment 15 Richard W.M. Jones 2013-10-29 14:48:18 EDT
I've just got around to using this new kernel and can report that
virtio-console/virtio-serial works, so thanks.

Note You need to log in before you can comment on or make changes to this bug.