Bug 1005555 - Unable to delete workspace when using Oracle database
Unable to delete workspace when using Oracle database
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity high
: ER4
: 6.0.0
Assigned To: Neus Miras
Jan Hrcek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 07:08 EDT by Jan Hrcek
Modified: 2014-08-06 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log with UNEXPECTED ERROR (95.28 KB, text/x-log)
2013-09-08 07:08 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-09-08 07:08:17 EDT
Created attachment 795319 [details]
Server log with UNEXPECTED ERROR

Description of problem:
When you use Orace as an underlying datasource, the application shows Unexpected error dialog (java.sql.SQLSyntaxErrorException: ORA-00932: inconsistent datatypes: expected - got BLOB) when you try to delete a workspace.

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER2 deployed on EAP 6.1; EAP configured to use Oracle version 11g R2 as a datasource.

How reproducible:
Always

Steps to Reproduce:
1. Configure EAP to use Oracle 11g R2 as datasource for dashbuilder
2. Login to dashbuilder application with root user
3. Select workspace Showcase and create duplicate of it using 'Duplicate workspace' button in the administrator bar.
4. Select duplicated workspace 'Copy of Showcase' and click 'Delete workspace' in the admin bar.

Actual results:
Unexpected error dialog appears displaying expection (see error log attached, search for UNEXPECTED ERROR), also the workspace is not deleted.

Expected results:
Deletion of workspace should be possible without exceptions

Additional info:
Marking this as test blocker, because our test suite relies heavily on Duplicate workspace functionality. To ensure test independence we must create and then delete workspaces. With this bug present we are unable to run more than 1/2 of our automated dashbuilder UI test suite.
Comment 1 Neus Miras 2013-09-10 11:42:54 EDT
The app throws this exception when a query over the database is executed to retrieve the panelInstances with an especiffic kpi configurated to check it it can be removed. This query fails on oracle because the restriction is over a field of type BLOB. We have changed the implementation to avoid this problem.
Now we do this check by software, iterating along the instances with kpi configurated.


Commits:
Master
https://github.com/droolsjbpm/dashboard-builder/commit/17effac120d0697509e0d61061c2e2016830d5ce

6.0.x
https://github.com/droolsjbpm/dashboard-builder/commit/8aed26e920d334bca7cf0ea716554c0468cad5ee
Comment 2 Neus Miras 2013-09-13 05:45:27 EDT
This change encapsulates the modification in PanelsManagerImpl to be more easy to update when hibernate lets do the query ober blob files. 

Commits:
Master
https://github.com/droolsjbpm/dashboard-builder/commit/2356be391cc383acdb2bc86a87beb7b87922146e

6.0.x
https://github.com/droolsjbpm/dashboard-builder/commit/8cb38a44c54c1b433734395217a32a9cbc6770a0
Comment 6 Jan Hrcek 2013-10-15 08:34:21 EDT
Verified with BPMS 6.0.0 ER4 + Oracle 11gR2

Note You need to log in before you can comment on or make changes to this bug.