Bug 1005581 - On ARM, qemu-kvm runs qemu-system-x86_64
On ARM, qemu-kvm runs qemu-system-x86_64
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
20
arm Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-09-08 13:48 EDT by Richard W.M. Jones
Modified: 2013-09-30 22:18 EDT (History)
10 users (show)

See Also:
Fixed In Version: qemu-1.6.0-8.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 22:18:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-09-08 13:48:18 EDT
Description of problem:

$ rpm -qf /usr/bin/qemu-kvm 
qemu-system-arm-1.6.0-6.fc20.armv7hl
$ uname -m
armv7l

ARM supports KVM.  This means qemu-kvm, if it exists, should
run qemu-system-arm (which is the binary that, on ARM, supports
KVM guests).  Having qemu-kvm run qemu-system-x86_64 on ARM
is confusing and wrong.

However I suspect that it's probably best for us to set a
date / Fedora release when we will drop qemu-kvm completely
and tell everyone about that.  The sooner the better IMHO.
In fact, why not for Fedora 20 / RHEL 7?

Version-Release number of selected component (if applicable):

qemu-system-arm-1.6.0-6.fc20.armv7hl

How reproducible:

100%

Steps to Reproduce:
1. Build libguestfs, run the test suite.

Actual results:

/usr/bin/qemu-kvm \
    -global virtio-blk-device.scsi=off \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -M vexpress-a9 \
    -machine accel=kvm:tcg,kernel_irqchip=off \
    -m 500 \
    -no-reboot \
    -kernel /home/rjones/d/libguestfs/tmp/.guestfs-1001/kernel.31868 \
    -dtb /home/rjones/d/libguestfs/tmp/.guestfs-1001/dtb.31868 \
    -initrd /home/rjones/d/libguestfs/tmp/.guestfs-1001/initrd.31868 \
    -device virtio-scsi-device,id=scsi \
    -drive file=liveness1.img,cache=writeback,format=raw,id=hd0,if=none \
    -device scsi-hd,drive=hd0 \
    -drive file=/home/rjones/d/libguestfs/tmp/.guestfs-1001/root.31868,snapshot=on,id=appliance,cache=unsafe,if=none \
    -device scsi-hd,drive=appliance \
    -device virtio-serial-device \
    -serial stdio \
    -device sga \
    -chardev socket,path=/home/rjones/d/libguestfs/tmp/libguestfs64Va3Q/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
    -append 'panic=1 console=ttyAMA0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=screen'
Supported machines are:
none                 empty machine
pc                   Standard PC (i440FX + PIIX, 1996) (alias of pc-i440fx-1.6)
pc-i440fx-1.6        Standard PC (i440FX + PIIX, 1996) (default)
pc-i440fx-1.5        Standard PC (i440FX + PIIX, 1996)
pc-i440fx-1.4        Standard PC (i440FX + PIIX, 1996)
pc-1.3               Standard PC
pc-1.2               Standard PC
pc-1.1               Standard PC
pc-1.0               Standard PC
pc-0.15              Standard PC
[etc]
Comment 1 Cole Robinson 2013-09-08 13:55:09 EDT
Ah, the intention was that qemu-kvm would only be shipped on x86 since that's the only real system we need to maintain back compat on. Sticking in POST since it's a simple spec change
Comment 2 Fedora Update System 2013-09-24 12:23:19 EDT
qemu-1.6.0-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qemu-1.6.0-8.fc20
Comment 3 Fedora Update System 2013-09-26 02:29:48 EDT
Package qemu-1.6.0-8.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.6.0-8.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17670/qemu-1.6.0-8.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-09-30 22:18:13 EDT
qemu-1.6.0-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.