Bug 100559 - Missing dependancies
Summary: Missing dependancies
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 12:49 UTC by Alan Cox
Modified: 2014-03-17 02:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-07 16:03:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2003-07-23 12:49:43 UTC
Initscripts sets up the console fonts but does not have a dependancy on the
console fonts being installed. It also doesnt suck in the keyboard map stuff
althogh I'm not 100% sure that it should - it just seems sensible
The network scripts (ifup) need dhclient but don't require dhcp - again not sure
if this is intentional because dhcp can be avoided. If so then dhcp is missing
from the dependancies for the redhat-config-network tool instead 8)

Comment 1 Bill Nottingham 2003-07-23 18:53:56 UTC
I'm unsure whether we really want to require in initscripts all the support
tools for *all* the interface types; this would reqiure dhclient, pppd,
isdn4k-utils, irda-utils, ipsec-tools, cipe, and rp-pppoe for all installs.

As for the console stuff, that should just gracefully do nothing if kbd isn't
installed. If it's showing errors, it needs fixed.

Comment 2 Eugenia Loli-Queru 2003-07-31 04:03:18 UTC
I also get dependancy problems, but from the Bluetooth module. Is this a known
problem or should I file a new bug report?

Comment 3 Bill Nottingham 2003-07-31 04:46:13 UTC
The kernel dependency failure is known, yes.

Comment 4 petrosyan 2004-06-05 15:36:58 UTC
regarding comment #1,
if kbd package isn't installed initscripts prints an ugly error
message can't set default font [FAILED] (in red letters).
this should be fixed.
this was reproduced in stock FC2 with all the updates.
Alan should change the version number ( 1 -> 2 )

Comment 5 Bill Nottingham 2004-06-07 15:01:46 UTC
Are you running in a non-unicode locale (just to make sure I've found
the right case where it fails...)

Comment 6 Alan Cox 2004-06-07 15:07:07 UTC
I was probably running unicode locale but couldnt be sure and can't
really check any more


Comment 7 Bill Nottingham 2004-06-07 16:03:55 UTC
Error case removed in cvs, will be in later initscripts builds.

Comment 8 petrosyan 2004-06-19 14:32:22 UTC
initscripts-7.57-2 still gives an error message if kbd package is not
installed.

Comment 9 Bill Nottingham 2004-06-25 20:53:03 UTC
Erm, later than 7.57-x. I should roll a new tarball at some point.


Note You need to log in before you can comment on or make changes to this bug.