Bug 1005590 - [abrt] general protection fault: 0000 [#1] SMP
[abrt] general protection fault: 0000 [#1] SMP
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:3216f3c0360e17e5995e1710e68...
:
: 1005517 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 16:55 EDT by Michael Hampton
Modified: 2013-12-08 11:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-08 11:33:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (73.44 KB, text/plain)
2013-09-08 16:55 EDT, Michael Hampton
no flags Details

  None (edit)
Description Michael Hampton 2013-09-08 16:55:24 EDT
Additional info:
reporter:       libreport-2.1.6
general protection fault: 0000 [#1] SMP 
Modules linked in: cts rpcsec_gss_krb5 xt_policy authenc esp6 xfrm6_mode_transport vhost_net macvtap macvlan ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc rfcomm xfrm4_tunnel tunnel4 ipcomp xfrm_ipcomp esp4 ah4 af_key bnep ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 ip6table_filter xt_conntrack nf_conntrack ip6_tables snd_hda_codec_hdmi acpi_cpufreq snd_hda_codec_realtek mperf kvm_amd snd_hda_intel kvm snd_hda_codec snd_hwdep snd_seq snd_seq_device btusb snd_pcm edac_core microcode joydev bluetooth serio_raw edac_mce_amd k10temp snd_page_alloc r8169 snd_timer sp5100_tco usblp rfkill snd i2c_piix4 mii soundcore nfsd auth_rpcgss nfs_acl lockd sunrpc uinput binfmt_misc dm_crypt usb_storage radeon i2c_algo_bit drm_kms_helper ttm ata_generic pata_acpi drm pata_jmicron i2c_core
CPU: 1 PID: 5534 Comm: chrome-sandbox Not tainted 3.10.10-200.fc19.x86_64 #1
Hardware name: MSI MS-7599/870S-G54 (MS-7599), BIOS V17.17 01/13/2012
task: ffff88020adbe320 ti: ffff8803d64cc000 task.ti: ffff8803d64cc000
RIP: 0010:[<ffffffff81202908>]  [<ffffffff81202908>] tid_fd_revalidate+0x78/0x180
RSP: 0018:ffff8803d64cddb8  EFLAGS: 00010206
RAX: ffff880416611680 RBX: ffff8802de8a0f40 RCX: 0000000000000015
RDX: 41491797ebd80000 RSI: 0000000000000000 RDI: ffff8802de8a1468
RBP: ffff8803d64cdde0 R08: ffff8802d0d89500 R09: ffff880229111460
R10: 0000000000000006 R11: 0000000000000000 R12: ffff8802d0d8a2d0
R13: ffff880240649b00 R14: 00000000000000ff R15: ffffffff811a9fc0
FS:  00007f10e51eb740(0000) GS:ffff88041f220000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 0000000001c1b008 CR3: 000000028a9dc000 CR4: 00000000000007e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Stack:
 ffff8803d64cddc8 ffff8802d0d8a2d0 ffff880240649b00 00000000000000ff
 ffff8802522c0780 ffff8803d64cde08 ffffffff81202a88 ffff8803d64cdea3
 0000000000000003 ffff8802082c5800 ffff8803d64cde68 ffffffff811ff079
Call Trace:
 [<ffffffff81202a88>] proc_fd_instantiate+0x78/0xa0
 [<ffffffff811ff079>] proc_fill_cache+0x119/0x150
 [<ffffffff81202a10>] ? tid_fd_revalidate+0x180/0x180
 [<ffffffff8120236a>] proc_readfd_common+0xea/0x1e0
 [<ffffffff81202a10>] ? tid_fd_revalidate+0x180/0x180
 [<ffffffff811a9fc0>] ? fillonedir+0xf0/0xf0
 [<ffffffff811a9fc0>] ? fillonedir+0xf0/0xf0
 [<ffffffff81202475>] proc_readfd+0x15/0x20
 [<ffffffff811a9d90>] vfs_readdir+0xb0/0xe0
 [<ffffffff811aa1e6>] SyS_getdents+0x86/0x120
 [<ffffffff81647c59>] system_call_fastpath+0x16/0x1b
Code: ff 48 85 c0 0f 84 e9 00 00 00 48 8b 50 08 44 3b 32 0f 83 d4 00 00 00 48 8b 52 08 4a 8d 14 f2 48 8b 12 48 85 d2 0f 84 c0 00 00 00 <44> 8b 6a 44 48 89 c7 e8 9c 0b fb ff 48 8d bb 28 05 00 00 e8 e0 
RIP  [<ffffffff81202908>] tid_fd_revalidate+0x78/0x180
 RSP <ffff8803d64cddb8>
Comment 1 Michael Hampton 2013-09-08 16:55:31 EDT
Created attachment 795419 [details]
File: dmesg
Comment 2 Michele Baldessari 2013-09-08 17:12:06 EDT
Hi Michael,

do you by chance have some steps on how to reproduce this? Or more information
as to what the system what doing when this was triggered?

There has been a similar report in the past but it has not gotten anywhere
due to lack of feedback: https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=915030

thanks,
Michele
Comment 3 Michael Hampton 2013-09-08 17:51:05 EDT
Hi Michele,

This happens intermittently when middle-clicking a link to open it in a new browser tab in Google Chrome. Less than an hour of browsing seems sufficient for it to occur, though it doesn't happen on any specific URL.

I was originally using google-chrome-stable-29.0.1547.65-220622.x86_64 from Google's repo. To eliminate the possibility of some closed source software causing the problem, I installed chromium-27.0.1453.93-2.fc19.x86_64 from spot's repo. The crashes continue even in chromium, and this particular crash is from using chromium.

Once this occurs, the system becomes largely unusable as many other programs begin crashing as well, and it must be rebooted.

Notably, I haven't yet observed these crashes in Firefox.

Thinking it might be a hardware-related issue, I also ran memtest86+ overnight, but this turned up no errors. I also checked the hard drives' SMART data and came up with nothing. I don't overclock this system.
Comment 4 Josh Boyer 2013-09-16 09:04:27 EDT
*** Bug 1005517 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2013-09-18 16:41:04 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 6 Michele Baldessari 2013-09-20 03:57:50 EDT
Hi Michael,

as there have been a bunch of proc changes in 3.11.1. Could you test with that kernel and let us know if the issue persists?

Thanks and regards,
Michele
Comment 7 Michael Hampton 2013-09-21 21:01:02 EDT
At the moment I can't even boot successfully with 3.11.1, for reasons I think are unrelated to this bug, so this may take some time. I'm still on 3.9.5...
Comment 8 Michele Baldessari 2013-11-26 15:59:32 EST
Hi Michael,

as there have been a bunch of proc changes in 3.11.9. Could you test with that kernel and let us know if the issue persists?

Note that 3.11.9 had a few fixes for certain machines/hw/nics that crashed it 
at boot. If it still does not boot, let me know why please.

Thanks and regards,
Michele
Comment 9 Michael Hampton 2013-12-08 11:33:41 EST
Hi Michele,

3.11.9 is finally stable on my system, and I am no longer seeing this issue on this kernel.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.