Bug 1005633 - win2k8-32 guest hang while running iozone more than 5 days
win2k8-32 guest hang while running iozone more than 5 days
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: 7.0
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 23:21 EDT by lijin
Modified: 2015-03-18 05:10 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-06 09:27:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lijin 2013-09-08 23:21:56 EDT
Description of problem:
boot 7 different windows guests in rhevm 3.2 and run iozone in each guest.After about 5 days' running,win2k8-32 guest hang.

Version-Release number of selected component (if applicable):
RHEV-toolsSetup_3.2_13.iso
virtio-win-prewhql-68
qemu-kvm-rhev-0.12.1.2-2.375.el6.x86_64
kernel-2.6.32-369.el6.x86_64
vdsm-4.10.2-22.0.el6ev.x86_64
libvirt-0.10.2-18.el6_4.8.x86_64

How reproducible:
twice in two weeks

Steps to Reproduce:
1.boot 7 different windows guests include win2k8-32 guest in rhevm 3.2
2.run iozone on system disk in each guest for more than 5 days:
  the iozone command:iozone.exe -az -b c:\aaaa -g 30g -y 64k

Actual results:
win2k8-32 guest hang after running iozone for 5 days

Expected results:
guest works fine,no hang

Additional info:
I will upload the NMICrashDump later.
the rhevm command:
/usr/libexec/qemu-kvm -name w2k8-32-longevi -S -M rhel6.4.0 -cpu Penryn -enable-kvm -m 2048 -smp 1,sockets=1,cores=1,threads=1 -uuid 050bfa04-56d0-40e9-9407-ab9df89a1220 -smbios type=1,manufacturer=Red Hat,product=RHEV Hypervisor,version=6Server-6.4.0.4.el6,serial=44454C4C-3100-1057-8054-B3C04F573258,uuid=050bfa04-56d0-40e9-9407-ab9df89a1220 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/w2k8-32-longevi.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=2013-09-02T14:18:27,driftfix=slew -no-shutdown -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x4 -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/rhev/data-center/mnt/10.66.90.115:_vol_s2bcao228623_isopool/87fa60aa-1dac-45c0-b0ca-66f8b9841d9f/images/11111111-1111-1111-1111-111111111111/RHEV-toolsSetup_3.2_13.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw,serial= -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=/rhev/data-center/fab0800a-b0fb-462c-821a-07b75eac0a03/3d2facdc-1605-4ccc-8f39-e2af02c77258/images/33b26296-4d02-49f5-a722-771269201151/6acf3068-66f5-4cb1-ad57-6f84611f550f,if=none,id=drive-virtio-disk0,format=raw,serial=33b26296-4d02-49f5-a722-771269201151,cache=none,werror=stop,rerror=stop,aio=threads -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=31,id=hostnet0,vhost=on,vhostfd=32 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:1a:4a:42:08:8b,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/w2k8-32-longevi.com.redhat.rhevm.vdsm,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/w2k8-32-longevi.org.qemu.guest_agent.0,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0 -chardev spicevmc,id=charchannel2,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=com.redhat.spice.0 -spice port=5902,tls-port=5903,addr=0,x509-dir=/etc/pki/vdsm/libvirt-spice,tls-channel=main,tls-channel=display,tls-channel=inputs,tls-channel=cursor,tls-channel=playback,tls-channel=record,tls-channel=smartcard,tls-channel=usbredir,seamless-migration=on -k en-us -vga qxl -global qxl-vga.ram_size=67108864 -global qxl-vga.vram_size=67108864 -incoming tcp:[::]:49152 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6
Comment 3 Vadim Rozenfeld 2014-02-04 02:08:42 EST
there were some critical bug fixes since virtio-win-prewhql-68.
Can we please retest with the most recent drivers from build-74?

Thanks,
Vadim.
Comment 4 Ronen Hod 2014-03-25 06:42:13 EDT
QE, Please retest with the latest build (at least 74).
Please inject NMI when the guest is stack once again.

Thanks.
Comment 5 lijin 2014-03-25 22:29:13 EDT
I will retest this scenario and it will take a few days,I will update this bug as soon as the result come out.
Comment 6 lijin 2014-04-07 22:14:43 EDT
after run iozone test for more than 5 days with virtio-win-prewhql-76,steps same as comment#0,guest works well,no hang,no error.
Comment 7 Vadim Rozenfeld 2014-07-04 10:04:16 EDT
(In reply to lijin from comment #6)
> after run iozone test for more than 5 days with virtio-win-prewhql-76,steps
> same as comment#0,guest works well,no hang,no error.

Can we close it as worksforme ?
Thanks,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.