This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 100566 - OpenOffice on RedHat 9 (Linux - Pentium 4 PC) generates Segmentation Fault
OpenOffice on RedHat 9 (Linux - Pentium 4 PC) generates Segmentation Fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 10:06 EDT by Ronald Stevens
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 11:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronald Stevens 2003-07-23 10:06:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en]C-20020130M  (Windows NT 5.0; U)

Description of problem:
Problem Description:  OpenOffice applications (Word, Calc, etc.) will not open. 
 
?	Tried reinstalling several times ? but this had no effect. 
?	This is a brand new intallation ? RedHat 9 ? on a new computer. 
?	Computer is a Gateway 700 Pentinum 4 PC ? with LCD monitor. 
?	Computer has NVidia GForce 4 graphics card. 
?	I needed to download the NVidia drivers to get the monitor to work. 
?	I modified the XF86Config file to get the NVidia drivers to work with the LCD 
monitor. 
 
 
The error message generated when OpenOffice tries to start is: 
 
?Checking for existing user installation ?   ?   NOT FOUND 
Performing first-time installation for user ?   /usr/bin/office: line 197: 6248 
Segmentation fault      /usr/lib/openoffice/program/setup 
?R:/etc/openoffice/autoresponse.conf 
?  FAILED? 
 
?	The initial setup (first run of OpenOffice) does not complete ? Actually, it 
doesn?t even start. 
? The .openoffice directory (normally created by the first run (oosetup) was not 
created in my HOME directory.   
 
I then removed and then reinstalled OpenOffice using the 
Add/Remove programs tool.  This had no effect.  The application still fails to 
load.  I then completely reinstalled Linux (Workstation) with all default 
parameters -- OpenOffice still fails to load.  I then removed and reinstalled 
OpenOffice with the Add/Remove programs tool again. And, OpenOffice still fails 
to run. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load RedHat 9 with OpenOffice
2. Try to start OpenOffice
3. OpenOffice fails
    

Actual Results:    OpenOffice seg faults - see problem description for error message

Expected Results:   OpenOffice should have worked

Additional info:

 The only thing a little out of the ordinary is the fact that I had to download new drivers for the NVidia graphics card and LCD monitor.  
The default RedHat 9 install does not install correctly the latest NVidia drivers.  However, I first booted in SINGLEUSER 1 mode - 
Loaded the NVidia drivers - Modified the XF86Config file - And then booted normally into runlevel 5 at which time the 'firstboot' 
process starts as normal.  I then created a standard user account.  At this point, I tried to start OpenOffice and it crashes every 
single 
time.

We are trying to make the decision to switch from Windows to Linux for our PC's.  OpenOffice products MUST run - otherwise Linux 
is 
NOT a viable option.
Comment 1 Rex Dieter 2003-12-09 11:58:07 EST
I'd recommend try using Fedora Core1/openoffice.org-1.1.0.  Works
nicely (though oo-1.0.2 on rh9 worked for me too).
Comment 2 Dan Williams 2004-02-27 11:32:59 EST
Please try current OOo 1.1.0, and reopen if problem still occurs

Note You need to log in before you can comment on or make changes to this bug.