Bug 1005703 - [RFE] backport sos command timeout support from upstream
[RFE] backport sos command timeout support from upstream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: 6.6
Assigned To: Bryn M. Reeves
David Kutálek
: FutureFeature
: 1147615 (view as bug list)
Depends On:
Blocks: 861266 1004793
  Show dependency treegraph
 
Reported: 2013-09-09 04:49 EDT by Martin Pavlik
Modified: 2015-04-06 23:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: sos-2.2-63.el6
Doc Type: Enhancement
Doc Text:
Feature: The sosreport command now applies a timeout when running all external commands. Reason: Depending on system configuration and fault state some commands may block indefinitely causing sos to appear to 'hang'. Result: Commands that block for an excessive period will now terminate with a timeout and do not cause the main sos process to hang.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pavlik 2013-09-09 04:49:24 EDT
Description of problem:
Please backport sos command timeout support from upstream

this request is based on
based on https://bugzilla.redhat.com/show_bug.cgi?id=1005066#c5

in this particular case timeout option would not solve the root cause of the issue, but it would prevent this whole class of problems by abandoning processes that go out-to-lunch on us
Comment 1 RHEL Product and Program Management 2013-10-13 22:19:53 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 Bryn M. Reeves 2013-11-26 13:37:27 EST
This should also include the timeout logging change that's now upstream:

commit 7649b791ee3372a660daad6e29666c2e1220486d
Author: Bryn M. Reeves <bmr@redhat.com>
Date:   Tue Nov 26 18:35:37 2013 +0000

    Log a warning when external commands time out
    
    Signed-off-by: Bryn M. Reeves <bmr@redhat.com>
Comment 5 Bryn M. Reeves 2014-09-29 11:19:06 EDT
*** Bug 1147615 has been marked as a duplicate of this bug. ***
Comment 6 errata-xmlrpc 2014-10-14 03:24:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1528.html

Note You need to log in before you can comment on or make changes to this bug.