Bug 1005708 - Failed to start component for RHQ Server Subsystems
Failed to start component for RHQ Server Subsystems
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server, Plugin -- Other (Show other bugs)
JON 3.2
x86_64 Linux
high Severity high
: ER04
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
:
Depends On: 1003797
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 05:02 EDT by Heiko W. Rupp
Modified: 2014-01-02 15:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003797
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2013-09-09 05:02:43 EDT
+++ This bug was initially created as a clone of Bug #1003797 +++

Sometimes resources under the RHQ Server Subsystem become unavailable:
Alert, Communications, Group Definition, Measurement, Remote API

In the agent.log the following exception keeps on coming

2013-08-29 09:49:27,311 ERROR [InventoryManager.discovery-1]
(rhq.core.pc.inventory.InventoryManager)- Failed to start component for Resource[id=11660,
uuid=4c3dedf1-8311-48dc-8484-3903b90dcef1, type={RHQServer}RHQ Server Remote API Subsystem,
key=rhq.remoting:type=RemoteApiMetrics, name=Remote API Subsystem, parent=RHQ Server Subsystems]
from synchronized merge.
org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource
Resource[id=11660, uuid=4c3dedf1-8311-48dc-8484-3903b90dcef1, type={RHQServer}RHQ Server Remote API
Subsystem, key=rhq.remoting:type=RemoteApiMetrics, name=Remote API Subsystem, parent=RHQ Server
Subsystems].
at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1831)
at
org.rhq.core.pc.inventory.InventoryManager.refreshResourceComponentState(InventoryManager.java:3226)
at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2815)
at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2821)
at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2821)
at org.rhq.core.pc.inventory.InventoryManager.processSyncInfo(InventoryManager.java:2821)
at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1145)
at org.rhq.core.pc.inventory.InventoryManager.synchInventory(InventoryManager.java:1115)
at org.rhq.core.pc.inventory.InventoryManager.handleReport(InventoryManager.java:1097)
at
org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:129)
at org.rhq.core.pc.inventory.RuntimeDiscoveryExecutor.call(RuntimeDiscoveryExecutor.java:64)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolE
xecutor.java:178)
at
java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor
.java:292)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
Caused by: org.rhq.core.pc.inventory.TimeoutException: [Warning] Call to
[org.rhq.plugins.server.RemoteAPIResourceComponent.start()] with args
[[org.rhq.core.pluginapi.inventory.ResourceContext@71903dd9]] timed out after 60000 milliseconds -
invocation thread will be interrupted.
at
org.rhq.core.clientapi.agent.PluginContainerException.wrapIfNecessary(PluginContainerException.java:
69)
at
org.rhq.core.clientapi.agent.PluginContainerException.<init>(PluginContainerException.java:96)
... 18 more

--- Additional comment from Heiko W. Rupp on 2013-09-03 06:15:56 EDT ---

Probably a dup / related to Bug 997601
Comment 1 John Mazzitelli 2013-10-07 14:30:41 EDT
I tried to fix this by re-building the connection on error. However, now I'm seeing this, as reported in BZ against JBoss EAP - bug #900595
Comment 2 John Mazzitelli 2013-10-07 17:21:33 EDT
git commit to master: 1558f53
Comment 3 Simeon Pinder 2013-10-24 00:09:50 EDT
Moving to ON_QA for testing in the next build.
Comment 4 Filip Brychta 2013-12-09 07:34:29 EST
Verified on:
Version :	
3.2.0.ER7
Build Number :	
e8e6401:ff0061d

The exception from description was not thrown once during 10 days of running -> moving to verified

Note You need to log in before you can comment on or make changes to this bug.