Bug 1005725 - mount.nfs can not parse the -o vers=3
mount.nfs can not parse the -o vers=3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.5
All Linux
high Severity high
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
: EasyFix, Reopened
Depends On: 1005721
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 05:25 EDT by Yin.JianHong
Modified: 2015-12-11 13:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1005721
Environment:
Last Closed: 2015-12-11 13:30:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix - v1 (1.67 KB, text/plain)
2014-05-23 09:50 EDT, Yin.JianHong
no flags Details

  None (edit)
Description Yin.JianHong 2013-09-09 05:25:19 EDT
+++ This bug was initially created as a clone of Bug #1005721 +++

Description of problem:
mount.nfs can not parse the -o vers=3

Version-Release number of selected component (if applicable):
RedHatEnterpriseServer 5.10
nfs-utils-1.0.9-69.el5

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
[root@dhcp-13-194 ~]# lsb_release -sir
RedHatEnterpriseServer 5.10
[root@dhcp-13-194 ~]# rpm -q nfs-utils
nfs-utils-1.0.9-69.el5
[root@dhcp-13-194 ~]# mount.nfs  -o vers=3  127.0.0.1:/tmp  /media/
usage: mount.nfs remotetarget dir [-rvVwfnh] [-t version] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, don't actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than failing.
        -h              Print this help
        version         nfs4 - NFS version 4, nfs - older NFS version supported
        nfsoptions      Refer mount.nfs(8) or nfs(5)

[root@dhcp-13-194 ~]# mount.nfs  -o nfsvers=3  127.0.0.1:/tmp  /media/
usage: mount.nfs remotetarget dir [-rvVwfnh] [-t version] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, don't actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than failing.
        -h              Print this help
        version         nfs4 - NFS version 4, nfs - older NFS version supported
        nfsoptions      Refer mount.nfs(8) or nfs(5)

[root@dhcp-13-194 ~]# echo $?
0
[root@dhcp-13-194 ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 5.10 Beta (Tikanga)
Kernel \r on an \m



Expected results:


Additional info:
mount  -o nfsvers=3  127.0.0.1:/tmp  /media/   # this works fine
mount.nfs  -o nfsvers=3  127.0.0.1:/tmp  /media/   #can not work

RHEL5.9 has same problem.
Comment 1 Yin.JianHong 2013-09-09 05:27:31 EDT
run in RHEL6.5-20130905.1
[root@ibm-x3550m3-03 ~]# mount.nfs -o vers=3  localhost:/tmp  /media/
usage: mount.nfs remotetarget dir [-rvVwfnsih] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)

[root@ibm-x3550m3-03 ~]# mount.nfs -o nfsvers=3  localhost:/tmp  /media/
usage: mount.nfs remotetarget dir [-rvVwfnsih] [-o nfsoptions]
options:
        -r              Mount file system readonly
        -v              Verbose
        -V              Print version
        -w              Mount file system read-write
        -f              Fake mount, do not actually mount
        -n              Do not update /etc/mtab
        -s              Tolerate sloppy mount options rather than fail
        -h              Print this help
        nfsoptions      Refer to mount.nfs(8) or nfs(5)

[root@ibm-x3550m3-03 ~]# lsb_release -sir
RedHatEnterpriseWorkstation 6.5
[root@ibm-x3550m3-03 ~]# rpm -q nfs-utils
nfs-utils-1.2.3-38.el6.x86_64
[root@ibm-x3550m3-03 ~]# cat /etc/issue
Red Hat Enterprise Linux Workstation release 6.5 Beta (Santiago)
Kernel \r on an \m
Comment 4 RHEL Product and Program Management 2013-10-13 22:19:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Steve Dickson 2014-05-23 06:21:38 EDT
mount.nfs is not the supported way to do NFS mount. 

mount -o vers=3 works
Comment 7 Yin.JianHong 2014-05-23 08:52:48 EDT
(In reply to Steve Dickson from comment #6)
> mount.nfs is not the supported way to do NFS mount. 
> 
> mount -o vers=3 works

In RHEL-7, it works fine;
I think we should fix(or improve) it.
Comment 8 Yin.JianHong 2014-05-23 09:50:37 EDT
Created attachment 898682 [details]
patch to fix - v1
Comment 9 Steve Dickson 2014-05-24 08:15:12 EDT
(In reply to Yin.JianHong from comment #7)
> (In reply to Steve Dickson from comment #6)
> > mount.nfs is not the supported way to do NFS mount. 
> > 
> > mount -o vers=3 works
> 
> In RHEL-7, it works fine;
> I think we should fix(or improve) it.

mount.nfs server:/export -o vers=3 also works... 

I would rather spend our resources working on other things...
Comment 10 Yin.JianHong 2014-05-25 21:18:47 EDT
Ok. But I still want to express different points of view:

GNU tools popular, one of the reasons is that there is no limited position of parameters and options;

And, that is easy to fix. So I try again to reopen..
  for our software with better user experience.
Comment 11 Steve Whitehouse 2015-12-11 13:30:25 EST
I agree with Steve D, no customer has run into this yet. We expect people to use the mount wrapper rather than mount.nfs directly. I don't think we need to fix this, and we should definitely focus on the more important bugs at this stage. It is apparently fixed in RHEL7 anyway (comment #2) and I don't think we need to back port it.

Note You need to log in before you can comment on or make changes to this bug.