Bug 1005739 - "service neutron-ovs-cleanup start" failing to start
"service neutron-ovs-cleanup start" failing to start
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-neutron (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terry Wilson
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 06:15 EDT by Martina Kollarova
Modified: 2016-04-26 12:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-0.8.b3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-07 13:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martina Kollarova 2013-09-09 06:15:58 EDT
Description of problem:
Packstack fails when starting service neutron-ovs-cleanup. Starting the service manually and running packstack again doesn't help.


Version-Release number of selected component (if applicable):
openstack-packstack-2013.2.1-0.4.dev740.el6.noarch
python-neutron-2013.2-0.3.b2.el6.noarch
python-neutronclient-2.2.6-2.el6.noarch
openstack-neutron-2013.2-0.3.b2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. packstack --allinone


Actual results:
ERROR : Error during puppet run : err: /Stage[main]/Neutron::Agents::Ovs/Service[ovs-cleanup-service]/ensure: change from stopped to running failed: Could not start Service[ovs-cleanup-service]: Execution of '/sbin/service neutron-ovs-cleanup start' returned 1:  at /var/tmp/packstack/8788692e282a40aaa66b8fee30480a69/modules/neutron/manifests/agents/ovs.pp:137

Expected results:
openstack deployed

Additional info:
# service neutron-ovs-cleanup start
# echo $?
1
# service neutron-ovs-cleanup stop
# service neutron-ovs-cleanup start
# echo $?
1
# service neutron-ovs-cleanup restart
# echo $?
0

# service --status-all|grep neutron
dnsdomainname: Unknown host
6    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 9696 /* 001 neutron incoming */ 
neutron-dhcp-agent dead but pid file exists
neutron-l3-agent dead but pid file exists
neutron-lbaas-agent is stopped
neutron-metadata-agent dead but pid file exists
neutron-openvswitch-agent dead but pid file exists
neutron dead but pid file exists


from /var/log/messages:

Sep  9 12:45:47 172-24-0-4 abrt: detected unhandled Python exception in '/usr/bin/neutron-ovs-cleanup'
Sep  9 12:45:47 172-24-0-4 abrtd: New client connected
Sep  9 12:45:47 172-24-0-4 abrt-server[30983]: Saved Python crash dump of pid 30978 to /var/spool/abrt/pyhook-2013-09-09-12:45:47-30978
Sep  9 12:45:47 172-24-0-4 abrtd: Directory 'pyhook-2013-09-09-12:45:47-30978' creation detected
Sep  9 12:45:47 172-24-0-4 abrtd: Package 'openstack-neutron-openvswitch' isn't signed with proper key
Sep  9 12:45:47 172-24-0-4 abrtd: 'post-create' on '/var/spool/abrt/pyhook-2013-09-09-12:45:47-30978' exited with 1
Sep  9 12:45:47 172-24-0-4 abrtd: Corrupted or bad directory '/var/spool/abrt/pyhook-2013-09-09-12:45:47-30978', deleting
Sep  9 12:46:05 172-24-0-4 abrt: detected unhandled Python exception in '/usr/bin/neutron-ovs-cleanup'
Sep  9 12:46:05 172-24-0-4 abrtd: New client connected
Sep  9 12:46:05 172-24-0-4 abrt-server[31010]: Not saving repeating crash in '/usr/bin/neutron-ovs-cleanup'
Comment 1 Martina Kollarova 2013-09-09 08:21:22 EDT
The image had some packages preinstalled for grizzly, but otherwise it was clean - no OpenStack installation was done on it before.
Comment 2 Martin Magr 2013-09-09 08:58:42 EDT
Currently we don't support upgrade via Packstack and looking at your machine I think that following is not good condition:

[root@rdo4-tempest ~]# cat /etc/passwd | egrep "(quantum|neutron)"
quantum:x:164:164:OpenStack Quantum Daemons:/var/lib/quantum:/sbin/nologin
neutron:x:164:164:OpenStack Quantum Daemons:/var/lib/neutron:/sbin/nologin

Please try on the OpenStack free machine and let me know if your issue still persists.
Comment 3 Martina Kollarova 2013-09-10 11:16:09 EDT
Yes, the problem is probably that I already had some grizzly packages installed. I knew packstack isn't able to upgrade a running openstack instance, but I thought it wouldn't have problems with the packages alone. I'll try it on a clean image ASAP.
Comment 4 Terry Wilson 2013-09-10 12:37:50 EDT
The issue is actually in the fedora neutron packages. They do not Require: python-pbr like the el6 havana ones do. Other projects patch around the python-pbr runtime dependency since it is just used for determining the version which can be done at build time. We may do that in neutron as well, but for now I'm taking the easy way out and just rebuilding with the requires, since we already use it for the el6 branches.
Comment 5 Terry Wilson 2013-09-10 14:16:22 EDT
Fix synced to openstack-havana/fedora-19 repo

Note You need to log in before you can comment on or make changes to this bug.