Bug 1005755 - loadvm is responded with "Error -22 while loading VM state"
loadvm is responded with "Error -22 while loading VM state"
Status: CLOSED DUPLICATE of bug 1007224
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Virtualization Maintenance
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 06:42 EDT by xhan
Modified: 2014-06-18 04:09 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:17:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xhan 2013-09-09 06:42:57 EDT
Description of problem:

The error happens while loading saved vm. 

Version-Release number of selected component (if applicable):
kernel:2.6.32-416.el6.x86_64
qemu-kvm:qemu-kvm-0.12.1.2-2.400.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. start vm
/usr/libexec/qemu-kvm \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -monitor stdio \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='win7-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idUt8YgM,mac='9a:2b:2c:2d:2e:2f',bus=pci.0,addr=0x3,id='idD1B5Cy' \
    -netdev tap,id=idUt8YgM,vhost=on,script= \
    -m 4096 \    
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'SandyBridge' \
    -M rhel6.5.0 \
    -device AC97,addr=0x6 \
    -drive file='test.qcow2',if=none,id=fdc0-0-0,media=disk,readonly=off,format=qcow2 \
    -global isa-fdc.driveA=fdc0-0-0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga qxl \
    -global qxl-vga.vram_size=33554432 \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm

2. execute "cont " to start the vm in human monitor
3. then launch "stop" in human monitor
3. save vm via human monitor
   (qemu)"savevm 1"
4. after that, load it.
   (qemu)"loadvm 1"

Actual results:
Error happens:
Error -22 while loading VM state

Expected results:
Should not response with errors.

Additional info:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Xeon(R) CPU           E5205  @ 1.86GHz
stepping	: 6
cpu MHz		: 1861.941
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 lahf_lm dts tpr_shadow vnmi flexpriority
bogomips	: 3723.88
clflush size	: 64
cache_alignment	: 64
address sizes	: 38 bits physical, 48 bits virtual
power management:
Comment 2 Qunfang Zhang 2013-09-16 06:48:51 EDT
This is a duplicate bug with bug 1007224, maybe need to close one of them.
Comment 3 Ademar Reis 2013-09-16 16:17:06 EDT
(In reply to Qunfang Zhang from comment #2)
> This is a duplicate bug with bug 1007224, maybe need to close one of them.

closing this one, as bug 1007224 is in POST state.

*** This bug has been marked as a duplicate of bug 1007224 ***

Note You need to log in before you can comment on or make changes to this bug.