Bug 1005760 - with default ISS master rhn-satellite-exporter / satellite-sync fails: MissingXmlDiskSourceFileError('unable to process file /tmp/aaa/orgs/orgs.xml',)
with default ISS master rhn-satellite-exporter / satellite-sync fails: Missin...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stephen Herr
Martin Korbel
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-09-09 06:53 EDT by Jan Hutař
Modified: 2013-10-01 17:54 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-backend-2.0.3-16-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-09 06:53:58 EDT
Description of problem:
When you have default ISS master satellite-sync fails: MissingXmlDiskSourceFileError('unable to process file /tmp/aaa/orgs/orgs.xml',) when reading dump created by rhn-satellite-exporter.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-2.0.3-12.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Create default master on slave setup page
   Admin -> ISS Configuration -> Slave Setup -> Add new master
     Default Master?: checked
2. # mkdir /tmp/aaa; rhn-satellite-exporter -d /tmp/aaa -c <some_channel>
     Note: I have used custom channel, but that is probably not important
3. # satellite-sync -m /tmp/aaa -l


Actual results:
06:37:24 Red Hat Satellite - file-system synchronization
06:37:24    mp:  /tmp/aaa
06:37:24    db:  rhnuser/<password>@rhnschema
06:37:24 
06:37:24 Retrieving / parsing orgs data
+++ sending log as an email +++

SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

MissingXmlDiskSourceFileError('unable to process file /tmp/aaa/orgs/orgs.xml',)
unable to process file /tmp/aaa/orgs/orgs.xml


Expected results:
Should work.
Comment 2 Stephen Herr 2013-09-09 10:58:21 EDT
Committing fix to Spacewalk master:
8f904c88528482c5941f1b60425656f10257a0f1
Comment 7 Martin Korbel 2013-09-13 01:58:17 EDT
VERIFIED on spacewalk-backend-2.0.3-17.el6sat

Reproduce steps from comment 0 on spacewalk-backend-2.0.3-12.el6sat.
Comment 8 Clifford Perry 2013-10-01 17:54:34 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.